WZ Editor 10
マニュアル

WZ soft > WZ Editor 10 > マニュアル >

設定

本ソフトウェアのカスタマイズや各種の動作の設定をするには、『表示メニュー:設定』を実行して設定ダイアログを開きます。

それぞれの設定項目のヘルプは、下記の操作でご覧ください。

  1. 設定ダイアログを開く前に『ヘルプメニュー:チップヘルプを表示』のONを確認
    OFFの場合は『チップヘルプを表示』を実行してチェックをONにします。
  2. 設定ダイアログで、ヘルプを見る項目をポイントする
    設定項目の解説がポップアップで表示されます。

設定ダイアログでは、[F1]で項目のヘルプを表示することもできます。

本マニュアルでは、設定項目を『設定ダイアログ:タブ名(:グループ名):項目名』として表記します。

設定項目の一覧

設定項目と解説を一覧表示で参照するには、『ヘルプメニュー:スマート設定』を実行して『スマート設定』画面をご覧ください。

WEBに同一の内容の設定項目一覧のページもございます。


スマート設定は、アウトライン形式で設定の一覧を表示します。

「ファイル設定」「表示設定」など大見出しをクリック、ダブルクリックして見出しの開け閉めをおこない、「開く」「保存」などの中見出しを開くと、設定項目の一覧が小見出しに表示されます。


設定項目の一覧は、設定項目名と現在の設定が表示されます。設定項目名の頭の[+]をクリックすると、項目の説明を表示します。

設定を変更すると直ちに適用となります。「表示設定」と「ファイル設定」の項目を変更した場合は、編集テキストに特有の「専用設定」に切り替えて設定を変更します。

設定の概要

WZ Editorの設定には、ファイル設定表示設定環境設定印刷設定色分け設定があります。

表示メニュー:設定』を実行すると表示される設定ダイアログでは、このうちのファイル設定、表示設定、環境設定を一括して設定します。


ファイル設定は、本ソフトウェアで扱うファイルの形式を登録します。

「C、C++プログラム」「JavaScript」「プレーンテキスト」など複数の形式を登録できます。

また、拡張子と形式の対応を登録できます。ファイルを開くときに拡張子に応じて使用するファイル形式が自動で選択されます。

アウトラインの見出しの認識、デフォルトで使用する表示設定と色分け設定も登録できます。


表示設定は、折り返し行数や行番号など、編集画面の表示を指定する設定です。

編集テキストのフォント、文字色、背景色、行間もこちらで設定します。

複数の設定を登録しておいて編集テキスト単位に切り替えて使用できます。


WZ10では、下記の表示設定が標準で登録されています。

表示設定を切り替えるには、『表示メニュー:表示設定の一覧』を実行、一覧から選択、表示を確認、『OK』を実行します。

専用設定
ファイル専用の表示スタイル
標準
一般のプレーンテキストの横書きの表示スタイル
Jテキスト
文書テキストの横書きの表示スタイル
縦書き
縦書きの表示スタイル
縦書き20*20(原稿用紙)
原稿用紙の表示スタイル
縦書き40*40(見開き)
本の見開きの表示スタイル
縦書き40*40
40文字×40行の縦書きの表示スタイル
俳句帳
俳句を数首並べる表示スタイル
レター
手紙の表示スタイル
雑誌原稿
一行文字数が少ない3段組の表示スタイル
横書き2段
横書き2段組の表示スタイル
メール
折り返しごとに改行されたメールの表示スタイル
プログラム
プログラムファイルやHTMLファイルの表示スタイル
マークダウンテキスト
マークダウン記法用の表示スタイル
タブ区切りテキスト
表形式データの表示スタイル
ボード
WZ Boardの表示スタイル
ビューアー
WZ10ヘルプの表示用のスタイル
コントロール
WZ10のリストボックスなどの表示用のスタイル

WZ Editorでは、縦書きと横書きを同時に表示した編集に対応しています。

下記の操作をおこないます。

  1. ウィンドウメニュー:多重化 別ウィンドウ』を実行。編集テキストが2つのウィンドウで表示されます
  2. それぞれのウィンドウで表示設定を切り替えます


環境設定は、キー定義(Windows標準/VZ/MIFES/Emacsライク/ユーザ定義)やウィンドウの表示方法などのカスタマイズを指定する設定です。環境設定は1つだけとなります。

色分け設定のデフォルトの色指定もこちらで設定します。


印刷設定は、印刷時の用紙サイズやヘッダ・フッタなどを定義する設定です。

複数の設定を登録しておいて編集テキスト単位に切り替えて使用できます。


色分け設定は、プログラム言語に応じた予約語やコメントの認識方法を定義する設定です。

複数の設定を登録しておいて編集テキスト単位に切り替えて使用できます。

設定の適用

ファイルを開くと、拡張子に応じて適用するファイル設定が決まります。ファイル設定から表示設定、色分け設定が決まって、テキストが表示されます。


上記にかかわらず、ファイル単位に設定をそれぞれ個別に選択することができます。

表示設定を選択するには、『表示メニュー:表示設定の一覧』を実行します。保存されている表示設定の一覧が表示されますので、使用したい名称をクリックすると表示が切り替わります。表示を確認して『OK』すると適用されます。


選択した設定は300ファイルまでプロファイルに記憶されますので、ファイルを閉じても次回のオープンで復元されます。プロファイルにはカーソル位置やアウトライン表示の状態も記憶されます。


ファイル設定を選択するには、『表示メニュー:ファイル設定の一覧』を実行します。表示設定の一覧とは異なり、リストから選択しただけでは設定は切り替わりません。『OK』すると切り替わります。色分け設定と印刷設定も同様となります。

色分け設定を選択するには『表示メニュー:色分け設定』を実行して『設定の一覧へ』をクリックします。

印刷設定を選択するには『ファイルメニュー:出力のプレビュー』を実行してツールバー左端の設定一覧コンボボックスから選択します。


加えてファイル単位に専用設定を使用することができます。

設定ダイアログで項目を変更してOKすると、設定を更新しますか?の問い合わせを表示します。ここで『専用設定にする』をクリックすると変更した設定をファイル専用として使用します。

専用設定は、「ファイル、表示、色分け、印刷」それぞれの設定の一覧ダイアログに「専用設定」と表示されますので、一覧から選択して使用することもできます。

専用設定の指定内容は、300ファイルまでプロファイルに記憶されます。

一時的な設定

下記でおこなった一時的な変更は、設定ダイアログの指定より優先されます。


一時的な変更は、設定には影響を与えません。

設定ダイアログを開いても、一時的な変更は反映されていません。

設定ダイアログをOKすると、一時的な変更は解除となります。

設定ダイアログ

表示メニュー:設定』を実行すると、設定ダイアログを表示します。ファイルに適用されているファイル設定と表示設定に加えて、環境設定の項目名と設定値が一括表示されます。印刷プレビュー表示では、表示設定の代わりに印刷設定の項目を表示します。

設定ダイアログのタイトルバーには、ファイルに適用されているファイル設定と表示設定の名称が表示されます。

色分け設定は、『表示メニュー:色分け設定』を実行して専用ダイアログでの設定となります。


表示設定と印刷設定の項目に限って、設定ダイアログで指定を変更するとリアルタイムにテキストの表示に反映しますので、フォントや文字間、行間などの設定変更の効果を画面表示で確認しながらの設定操作が可能です。

ファイル設定と環境設定の項目は、設定ダイアログをOKすると反映されます。


ファイル設定や表示設定、印刷設定の設定値を変更して設定ダイアログをOKすると、更新の問い合わせ(更新する専用設定にするキャンセル)を表示します。

設定ダイアログの設定操作メニュー

設定ダイアログの『設定の操作』をクリックすると、下記のメニューを表示します。

編集テキスト専用の設定を使用
テキスト専用の表示設定とファイル設定に切り替えます。
表示設定の切り替え
表示設定の一覧を表示して選択します。
表示設定の新規作成
表示設定を新規に作成します。
表示設定のメンテナンス
表示設定の一覧ダイアログを表示して、新規作成・削除などのメンテナンスをおこないます。
ファイル形式の切り替え
ファイル設定の一覧を表示して選択します。
ファイル形式の新規作成
ファイル設定を新規に作成します。
ファイル形式のメンテナンス
ファイル設定の一覧ダイアログを表示して、新規作成・削除などのメンテナンスをおこないます。
環境設定の初期化
環境設定のすべての項目を初期値に戻します。

メンテナンス』を実行すると表示される「設定の一覧」ダイアログでは、下記の操作がおこなえます。

編集
一覧で選択した設定を編集するダイアログを表示します。
ダイアログには、項目名と設定の一覧を表示します。
名前の変更
一覧で選択した設定の名前を変更します。
名前を付けて保存
一覧で選択した設定に名前を付けて新しい設定を追加します。
新規作成
一覧で選択した設定をコピーして新しく設定を作成します。
削除
一覧で選択した設定を削除します。
↑、↓
一覧で選択した設定の表示の順序を上または下へ移動します。
開く
設定を保存しているテキストファイルを直接、本ソフトウェアで開いて編集します。
初期化
ユーザ操作にておこなった設定項目の変更や設定の追加をクリアして、初期状態に戻します。

拡張子とファイル設定の関連付け

ファイルを開くと拡張子によってどのファイル設定を使用するかが決定されます。

ユーザ操作で使用するファイル設定を指定した場合は、指定が優先されます。


WZ10では、下記のファイル設定が標準で登録されています。

プレーンテキスト
txtファイル(WZ10標準のテキスト形式)
下記に記述のないファイル拡張子にも適用
Jテキスト
textファイル(WZ10標準の文書テキスト形式)
C、C++プログラム
c・h・cpp・txcファイル
C、C++プログラム(制御文認識)
if、else、case、return文を含む行を太字で表示
関連付け拡張子なし
C#プログラム
csファイル
JAVAプログラム
javaファイル
JavaScript
jsファイル
PHPプログラム
phpファイル
Phytonプログラム
pyファイル
その他のプログラム
asm・bas・cgi・css・for・hsp・ini・lisp・mscr・pas・pl・rb・ruby・sql・v・vhd・vhdlファイル
HTMLテキスト
htm・html・shtml・xml・xhtmlファイル
TeXテキスト
texファイル(TeX用のファイル)
タブ区切りテキスト
tsvファイル(表計算データファイル)
CSVテキスト
csvファイル(表計算データファイル)
青空文庫テキスト
≪≫のルビ、青空文庫の装飾と体裁(関連付け拡張子なし)
マークダウンテキスト
mdファイル
JISテキスト
\_^親文字(ルビ)\^_、JIS形式に対応(関連付け拡張子なし)
脚本
scrファイル
メールテキスト
mailファイル(自動整形がONのメール編集用)
Wordテキスト
Microsoft Wordで作成してテキスト形式で保存した文書
ルビを()で表記(関連付け拡張子なし)
PDF Book
PDF BookはWZ9で編集、Readerで閲覧が可能
WZ Board
memファイル(WZ Board専用)
体裁
txzファイル(WZ6の体裁文書)
TML
tmlファイル(WZ5/WZ4のTMLファイル)


拡張子とファイル設定の対応を変更するには、下記の操作をおこないます。


拡張子のファイル設定の割り当てを解除するには、下記の操作をおこないます。

割り当てのない拡張子は、デフォルトの`テキスト`のファイル設定が使用されます。

デフォルトの表示、色分け、印刷設定

ファイル設定に、デフォルトで使用する表示設定と色分け設定を指定できます。


ファイルを開くと、拡張子からファイル設定を決定し、ファイル設定のデフォルトの「表示、色分け」設定を使用します。(ユーザ操作で使用する「ファイル、表示、色分け、印刷」設定を指定した場合は、指定が優先されます)


ファイル設定にデフォルトの設定を指定するには、下記の操作をおこないます。

  1. 表示メニュー:ファイル設定の一覧』を実行
  2. 一覧から指定するファイル設定を選択
  3. 編集』をクリック
  4. 標準の表示設定』『標準の色分け設定』『標準の印刷設定』を指定してOK

設定のバックアップと移行

設定をバックアップするには、下記の操作をおこないます。

  1. ヘルプメニュー:バージョン情報』を実行
  2. 設定フォルダを開く』をクリック
    設定フォルダがエクスプローラで開きます。
  3. 設定フォルダのすべてのファイルをUSBメモリなどへコピー
    サブフォルダはコピーする必要はありません。


設定を復元するには、下記の操作をおこないます。

  1. エクスプローラで設定フォルダを開く
  2. 本ソフトウェアをすべて終了
  3. USBメモリなどから上書きコピーを実行

文字の表示

DirectWriteの文字の表示

設定ダイアログ:フォント:文字の描画』を精細または高精細に指定すると、テキストの文字をDirectWriteで高品質で表示します。

高精細を指定すると、DirectWriteに加えてDirectDrawによる垂直方向の文字のアンチエイリアシング表示をおこないます。詳細よりも滑らかな文字の表示となります。高精細は、Windows10と8.1のみで有効です。Windows7と8では精細の描画となります。

精細を指定した場合で「MS明朝」「MSゴシック」のフォントサイズ16ポイント未満は、従来の文字描画となります。

DirectWriteの縦書き表示

WZではDirectWriteの縦書き表示にも対応します。

文字の描画』が高精細の場合はWindowsの機能で縦書き表示をおこないます。縦中横の文字の位置がずれる場合は、『設定ダイアログ:フォント:縦書き:微調整』の『縦中横』の数値指定で表示を調整できます。

文字の描画』が精細の場合は、WZ独自の縦書き表示をおこないます。下記のフォントで動作を確認しています。その他のフォントの表示は、サポートの対象外となります。

WZ独自の縦書き表示は、下記の制約があります。

Unicode特有文字の縦書き

文字の描画』に精細を指定すると、Unicode特有文字の縦書き表示に対応します(表示のみの対応となります。一部対応しない文字もあります)。

基本を指定すると、Unicode特有文字は横書きの表示となります。

UnicodeのCombining Diacritical Marks

WZ Editorでは、Combining Diacritical Marksの表示、印刷、PDF出力に対応しています。

Combining Diacritical Marksの記号(文字コードU+0300〜U+036F)を入力すると、直前の文字に記号を重ねて表示します。

「Arial Unicode MS」フォント以外の対応となります。

文字組版表示

日本語と欧文の間に自動で余白を空ける、読みやすい文章の表示に対応します。

DTPと同様に折り返しのそれぞれの行の末尾を揃えたり、括弧やルビの余白と折り返しの調整にも対応します。文字組版表示をおこなうには、下記の設定をおこないます。

  1. 表示メニュー:設定』を実行
  2. 「フォント」タブをクリック
  3. 「組版」グループの「文字組版」をONにしてOK

タグの表示

WZ Editorでは、HTML、Jテキスト、TeX、青空文庫、JIS、体裁文書、TML文書で使用されるタグの表示を消して本文だけを表示することができます。

タグの表示をOFFにするには、『表示メニューのタグの全表示』を実行します。再度コマンドを実行するとタグの表示をONにします。

下記のカスタマイズをおこなうと、印刷プレビューと印刷時に自動でタグの表示をOFFにできます。

  1. 表示メニュー:設定』を実行
  2. スタイル』タブをクリック
  3. 印刷でタグを表示しない』をONにしてOK

ルビの表示

設定ダイアログ:スタイル:基本のスタイル:ルビの表示』の指定で、ルビの表示を本文の50%、75%、35%、表示OFFに切り替えできます。

図の表示

設定ダイアログ:スタイル:基本のスタイル:図の表示』の指定で、図の大きさを100%、50%、33%、25%、表示OFFに切り替えできます。

メニュー操作『表示メニュー:画像の表示』からでも同じ指定がおこなえます。

色分け

テキストの文字、範囲選択の表示色や、偶数段落行の背景色のカスタマイズをするには、下記の操作をおこないます。

  1. 表示メニュー:設定』を実行して、設定ダイアログの『色分け』タブをクリック
  2. 文字』『選択文字』『選択背景』などに色を指定してOK

プログラムの予約語、タグ、検索文字列、URLの表示色や太字などの装飾も上記のダイアログで設定できます。

予約語などの指定は、下記の「色分け設定」でおこないます。

色分け設定の切り替え

「色分け設定」は、プログラム言語に応じた予約語やコメントの認識方法を定義する設定です。

複数の設定を登録しておいて編集テキスト単位に切り替えて使用できます。デフォルトで各種のプログラム言語の色分け設定が登録されています。


WZ10では、下記の色分け設定が標準で用意されています。

標準、自動判別、HTML、PHPプログラム、css、TeX、iniファイル、MortScript、UNIXシェルスクリプト、Cプログラム、JAVAプログラム、PERLプログラム、RUBYプログラム、SQLプログラム、VHDLプログラム、アセンブラ、フォートラン、BASICプログラム、PASCALプログラム、LISPプログラム、PYTHONプログラム

色分け設定標準はテキスト文書用です。検索文字列、URL、タグの色分けをおこないます。

その他の設定はプログラム用です。

自動判別を指定すると、ファイル拡張子によって自動で使用する色分け設定を切り替えます。


色分け設定を切り替えるには、『表示メニュー:色分け設定』を実行、『設定の一覧へ』をクリック、一覧で選択してOKすると切り替わります。指定した設定は、ファイルのプロファイルに記憶されます。


ファイル単位で専用の色分け設定を使用できます。上記の一覧で専用設定を選択してOKします。設定内容はファイルのプロファイルに記憶されます。

プログラムの色分け

プログラムファイルを開くと、拡張子によってプログラム言語に対応した色分け表示をします。

色分けは、コメント、識別子、文字列、数値、予約語、演算子が対象となります。

プログラム言語に応じて色分け表示の対応状況が異なります。


C・C++プログラムでは、下記の色分けをおこないます。

テキストの色分け

テキスト文書は、デフォルトで検索文字列、URL、タグが色分け表示されます。

色分け設定の編集

色分け設定を編集するには、『表示メニュー:色分け設定』を実行して色分けダイアログを表示します。


色分けダイアログでは、色分けの種類と表示色を指定した色分け項目を複数登録できます。

色分け項目を登録するには下記の操作をおこないます。複数の色分け項目を追加するには、この操作を繰り返します。色分け項目は、30000個まで登録が可能です。

  1. 追加』をクリックして新規項目を追加します。
  2. ステータス』をOKにします。SKIPにすると、項目の色分けが無効となります。
  3. 色の指定』から色を選択します。検索文字列予約語を指定すると、『設定ダイアログ:色分け』で指定した色で表示します。直接指定を選択すると、ダイアログで『』『太字』『下線』『斜体』を指定できます。
  4. 種類』『文字列』『オプション』を指定します。詳細は、下記の「種類と文字列の指定」と「オプションの指定」をご覧ください。
  5. コメント』には、色分け指定の目的などの説明を入力できます。


たとえば、プログラムの予約語や特定の文字を色分け表示するには、下記を指定します。

  1. 種類』に英単語または語句を指定します。
    漢字のキーワードを色分けする場合は、語句を指定します
  2. 文字列1』に色分けするキーワードを空白で区切ってabc defのように指定します。

予約語や特定の文字をファイルで指定するには、下記の操作をおこないます。

  1. 改行または空白区切りでキーワードをテキストファイルに作成します。拡張子は.tkwを推奨します。
    日本語の語句を含む場合は、テキストファイルの文字コードをSJIS-EXで保存します。
  2. 文字列1』にfile://フルパスのファイル名file://c:\Users\Home\xxx.tkwのように指定します。

種類と文字列の指定

英単語
文字列1』に指定した英単語を色分けします。英単語は半角空白で区切ってabc defのように指定します。
英単語をファイルで指定するには、『文字列1』にfile://に続けてファイル名をフルパスまたは標準フォルダの相対パスでfile://c:\color.tkwfile://color.tkwのように指定します。
ファイルには、単語を半角空白か改行で区切って指定します。
英単語(大小区別なし)
英単語の大文字と小文字の区別をしないで色分けします。
語句
文字列1』に指定した日本語の語句を色分けします。語句は半角空白で区切って指定します。英単語と同様にファイルによる指定も可能です。
正規表現
文字列1』で指定した正規表現で色分けします。『タグ1』に15を指定すると正規表現のタグ1〜タグ5で記憶した部分の色分けも可能です。
行末
文字列1』で指定した文字から行末までを色分けします。
行末(正規表現)
文字列1』で指定した正規表現から行末までを色分けします。
段落内範囲
1段落の範囲内で『文字列1』〜『文字列2』で指定した範囲を色分けします。段落にまたがる色分けはおこないません。
広範囲
文字列1』〜『文字列2』で指定した範囲を色分けします。段落にまたがる色分けにも対応します。『広範囲(正規表現)』と合わせて6個まで指定できます。
広範囲(正規表現)
文字列1』〜『文字列2』の正規表現で指定した範囲を色分けします。段落にまたがる色分けにも対応します。『広範囲』と合わせて6個まで指定できます。
URL
URLを内蔵プログラムで判別して色分けします。
"ファイル名"
テキストの"ファイル名"の表記でファイルが存在するものを色分けします。
C言語コメント
C・C++言語の//から行末まで、/*から*/までの範囲を色分けします。段落にまたがる色分けにも対応します。
Pythonブロックコメント
Pythonの"""の行から次の"""の行までと、'''の行から次の'''の行までを色分けします。
#if条件
C・C++言語の#if〜#else〜#endifの有効部分と無効部分を判定して、無効部分をコメント色などの指定した色で色分けします。#if 0〜#endifの範囲は、無効部分と判定します。
文字列1』に識別子を半角空白で区切って複数指定できます。#if 識別子〜#endif#if defined(識別子)は有効部分と判定します。#if !defined(識別子)は無効部分と判定します。
文字列1』に指定のない識別子の#if defined(識別子)は無効部分、#if !defined(識別子)は有効部分と判定します。
文字列1』に!識別子を指定した場合は、#if 識別子〜#endifを無効部分と判定します。
オプション』にnodefを指定すると、definedの判定をOFFにします。
検索文字列
検索ダイアログで指定した検索条件で色分けします。
検索結果が複数の行にまたがる場合は、1行目のみの色分けとなります。
複数行にまたがる正規表現の場合は、色分けなしとなります。テキストバッファのギャップ付近では、色分けがなされない場合があります。
タグ
HTMLのタグを色分けします。
タグの属性
HTMLのタグの属性部分を色分けします。
テキストタグ
文字スタイルや段落スタイルを指定する記号や、マークダウンテキストの記号を色分けします。

オプションの指定

オプション』には、優先度や色分け文字列の詳細設定を指定します。

複数のオプションを指定するには、半角空白で区切ります。


inc
上位レベルの色分けを含む文字列を色分け表示します。
デフォルトでは、上位レベルを含む色分けは無効となります。
over
上位レベルの色分けを含む文字列を色分け表示します。上位レベルの色分けは無効化します。
デフォルトでは、上位レベルを含む色分けは無効となります。
esc
=に続けてエスケープする文字をesc=\のように指定します。エスケープに続く一文字は範囲末尾の判定から除外します。段落内範囲の専用オプションとなります。
s1
文字列1』も含めて色分け表示します。段落内範囲の専用オプションとなります。
s2
文字列2』も含めて色分け表示します。段落内範囲の専用オプションとなります。
icase
半角英字の大文字と小文字を区別しないで色分けします。
nodef
#if defined(識別子)#if !defined(識別子)の色分けをOFFにします。#if条件の専用オプションとなります。

色分けの詳細

色分けは字句解析のパターンマッチングで表示します。構文解析を実行しないためプログラム言語の完全な色分けには対応しておりません。

色分けのパターンマッチングは、色分け設定の先頭の項目から順に実行します。

プログラム言語のコメントの色分けは、項目を下記の順位で指定します。

  1. 上位に文字列URLなど、コメントの開始記号にマッチする可能性のある文字列を含む項目を指定します。
  2. 下位にコメントの色分け項目を指定して、オプションにincまたはoverを指定します。
    incを指定すると、コメント内の文字列など上位の字句を色分け表示します。
    overを指定すると、コメント内の文字列もコメントの色で表示します。

キーカスタマイズ

下記の設定操作でユーザキー定義を追加することができます。

  1. 表示メニュー:設定』を実行
  2. インターフェース』タブをクリック
  3. ユーザ追加定義』をON
  4. ユーザ追加定義』の『...』をクリック、「定義ファイル編集」ダイアログを表示
  5. 「コマンド一覧」から追加するコマンドを選択
  6. 「キー定義」に追加するキーを指定
  7. 追加』をクリック
  8. 「定義ファイル編集」で『ファイルメニュー:保存して閉じる』を実行

設定ダイアログをOKすると追加したキー定義が有効となります。

有効にならない場合は、本ソフトウェアをすべて終了して再起動すると有効になります。


キーにはコマンドの他に、「文字列」「コマンドマクロ」「Text-Cプログラム」「検索など」を割り当てできます。

割り当てをおこなうには、「定義ファイル編集」でコマンド名を直接書き換えます。

文字列
全角文字列は文字列をそのまま指定します。
半角文字列は引用符で括ってABCのように指定します。
指定した文字列がテキストに挿入されます。
コマンドマクロ
kbm: コマンド、文字列、引数付きコマンドの並びを指定します。
(例)kbm: right right "文字列" left leftは、「右2回カーソル移動、"文字列"の入力、左2回カーソル移動」の指定となります
Text-Cプログラム
アプリケーションやツールの名前を\\system\txgrep.cのように指定します。
プログラムのファイル名をc:\macro\mymacro.cのように指定します。main関数から実行されます。
プログラムのファイル名+関数名をfunc@c:\macro\mymacro.cのように指定します。
search("検索文字列")
カーソル位置から文字列を検索します。
file("ファイル名")
ファイルを開きます。
view("表示設定名")
表示設定を切り替えます。
tag("ファイル設定名")
ファイル設定を切り替えます。
color("色分け設定名")
色分け設定を切り替えます。
lpsty("印刷設定名")
印刷設定を切り替えます。
jmpara(段落番号)
段落へジャンプします。
rightb(移動バイト数)
移動バイト数のジャンプをします。
jmpadr(ジャンプ先アドレス/先頭=0)
アドレスへジャンプします。
アドレスはテキスト先頭を0としたバイト数で指定します。
ly(カーソルジャンプ行)
カーソルを画面の指定行数(画面先頭行=1)へジャンプします。

メニューのカスタマイズ

下記の操作でメニューにのコマンドを追加することができます。

  1. ツールメニュー:カスタマイズ:ユーザメニューのカスタマイズ』を実行
  2. 「定義ファイル編集」の「コマンド一覧」から追加するコマンドを選択
  3. 追加』をクリック
    「定義内容」に「コマンド」「タブ」「説明」の行が追加されます
  4. 「定義ファイル編集」を上書き保存して閉じる

ツールメニュー:ユーザメニュー』を実行すると、カスタマイズしたメニューを表示します。

キーのカスタマイズと同様に、「文字列」「コマンドマクロ」「Text-Cプログラム」を割り当てできます。

メニューのフルカスタマイズ

メニューバーをフルカスタマイズして不要なコマンドを削除すると、必要なコマンドを実行するステップ数が削減できます。

メニューバーをフルカスタマイズするには、下記の操作をおこないます。

  1. 表示メニュー:設定』を実行
  2. ウィンドウ』タブをクリック
  3. メニューバー』にユーザ定義を選択して、『...』をクリック
  4. 「定義ファイル編集」で定義内容をカスタマイズ
  5. ファイルメニューから「保存して閉じる」を実行
  6. 設定ダイアログをOK

ツールバーのカスタマイズ

ツールバーのカスタマイズにより不要なボタンを削除したり、使用頻度の高いコマンドを追加して1クリックで実行できます。

ツールバーをカスタマイズするには、下記の操作をおこないます。

  1. 表示メニュー:設定』を実行
  2. ウィンドウ』タブをクリック
  3. ツールバー』にユーザ定義を選択して、『...』をクリック
  4. 「定義ファイル編集」で定義内容をカスタマイズ
  5. ファイルメニューから「保存して閉じる」を実行
  6. 設定ダイアログをOK

行単位のカットアンドペースト

Windows標準キー定義をご使用の場合は、下記の設定操作で[Shift+横方向キー]で文字選択、[Shift+縦方向キー]で行選択にカスタマイズすることができます。

  1. 表示メニュー:設定』を実行
  2. インターフェース』タブをクリック
  3. 方向キーの範囲選択』に行/文字単位を指定してOK

行選択でコピーしたテキストの貼り付けは行単位となり、行の途中で貼り付けを実行した場合でも行頭に貼り付けされます。


VZライクキー定義では、[Ctrl+B]で文字単位/段落単位の選択コマンドを使用できます。


MIFESライクキー定義では、[Shift+F6]で文字単位、[F6]で行単位の選択コマンドを使用できます。

音声化

WZの音声化をONにするには、WZ10を下記のコマンドラインで起動します。

wzeditor.exe /speak

音声化をOFFにするには、下記のコマンドラインで起動します。

wzeditor.exe /speak(0)

WZの音声化は、「XP Reader」(株式会社システムソリューションセンターとちぎ)に対応しています。

音声化すると、下記のキー操作が追加されます。

][
行を移動して移動先の行を読み上げ
][
一文字移動して移動先の文字を読み上げ
Shift+Down][Shift+Up][Shift+Left][Shift+Right
選択する
Ctrl+Left
一語左へ移動して移動した語句を読み上げ
Ctrl+Right
一語右へ移動して移動した語句を読み上げ
Insert
挿入/上書きモードを切り替え、モードを読み上げ
Delete
「削除」と「カーソル文字」を読み上げて、削除
選択時は「削除」と「範囲内」を読み上げて、範囲内を削除
Backspace
「後退」と「削除する文字」を読み上げて、削除
選択時は「削除」と「範囲内」を読み上げて、範囲内を削除
Ctrl+F
音声付きの検索
Ctrl+Alt+H
カーソルの文字を読み上げ
Ctrl+Alt+L
カーソル行と桁数を読み上げ
Shift+Ctrl+Alt+K
前の句点へ移動して次の句点まで読み上げ
Ctrl+Alt+K
次の句点へ移動して次の句点まで読み上げ
Shift+Ctrl+Alt+D
前の読点へ移動して次の読点まで読み上げ
Ctrl+Alt+D
次の読点へ移動して次の読点まで読み上げ
Shift+Ctrl+J
行頭からカーソル位置まで読み上げ
Shift+Ctrl+L
カーソル位置から行末まで読み上げ
Shift+Ctrl+I
一行上の行を読み上げ
Shift+Ctrl+P
一行下の行を読み上げ
Shift+Ctrl+B
一行上の段落先頭へ移動して段落を読み上げ
Shift+Ctrl+M
一行下の段落先頭へ移動して段落を読み上げ
Ctrl+Alt+F
音声付きの文字種類「全角カタカナ」「半角カタカナ」「全角英文字」「半角英文字」「漢字」の検索
指定の文字種へジャンプして行を読み上げ
Shift+Ctrl+K
現在行の読み上げ
Shift+Ctrl+U
現在段落の読み上げ
Ctrl+Up
現在段落を読み上げて段落の先頭に移動
段落の先頭の場合は、前の段落へ移動
Ctrl+Down
現在段落を読み上げて次の段落の先頭に移動
PageTop