WZ Editor 10
マニュアル

WZ soft > WZ Editor 10 > マニュアル >

対応するファイルタイプ

WZ10では、下記の10種類に分類されるファイルを扱うことができます。

文書
プレーンテキスト/Jテキスト/青空文庫テキスト/脚本テキスト
それぞれ、一般のテキストファイル/日本語文書/小説/脚本の用途です。
他の文書
JISテキスト(WZ9~7)/体裁(WZ6)/TML(WZ5~4)
過去のWZの文書ファイルのオープンと編集に対応します。
PDF Book
WZで作成したPDFファイルはPDF Book形式となり、印刷イメージに加えて出力元の文書ファイルが保存されています。
「PDF Book」をWZで開くと文書を編集してPDFの印刷イメージを更新できます。
HTML関連
HTML/マークダウンテキスト
HTMLのタグや属性をダイアログで入力できます。Emmetの省略記法に対応します。マークダウン記法によるHTML作成にも対応しますが、WZ10ではJテキスト+HTML出力を推奨します。
TeX
TeXコマンドの補完入力、アウトライン、各種のTeX編集支援機能に対応します。
データ
タブ区切りテキスト(TSV)/CSVテキスト
表形式での表示、データのソートに対応します。
プログラム
C/C++/C#/Java/JavaScript/PHP/Python/その他14言語
関数/クラス定義のアウトライン/検索/リファレンス、変数/関数/構文/メソッド/メンバの補完入力、予約語/文字列/数値/コメント/演算子の色分け表示に対応します。
Zip、Epub
アーカイブ内のファイルオープンと編集に対応します。(ZIPダイレクト編集)
イメージ
画像を表示します。
バイナリ
バイナリ編集モードで開いて編集に対応します。

プレーンテキスト

.txtファイルは、プレーンテキストとして開きます。例外として「青空文庫」や「JISテキスト」と判定されたファイルは、青空文庫やJISとして開きます。

また、Jテキスト/TML/TSV/CSV/HTML/TeX/プログラム/イメージ/バイナリ以外の拡張子のファイルも、プレーンテキストとして開きます。

色分け表示は、行頭の`#コメント`、行頭の`>引用`、URL、検索文字列に対応します。


俯瞰メニュー:アウトライン』を実行すると、編集領域の右側のアウトラインに、WZ形式による見出しのアウトラインの表示をおこないます。

見出しは、段落先頭の半角ピリオドで表します。

.見出し1

..見出し2

...見出し3

....見出し4

.....見出し5

......見出し6

スマート入力

プレーンテキストのスマート入力は、日本語語句と英単語の入力の対応となります。

英単語のスマート入力は、編集テキストから入力文字列に部分が一致する単語を検索して候補へ追加します。

編集テキストに加えて、『設定ダイアログ:入力:単語補完辞書1〜4』`で指定したファイルからも英単語の入力候補を検索します。

リファレンス

プレーンテキストのリファレンスは、クイックGrepの利用が可能です。

編集テキストの英単語にカーソルを合わせて[Shift][Shift]で、編集テキストのフォルダでグローバル検索(クイックGrep)を実行して、英単語を含む見出しがある場合はそのファイル名を表示します。

クイックGrepはフォルダのすべてのファイルが対象となりますので、プレーンテキスト以外のプログラムの関数定義も低い優先度で表示されます。

リファレンスの末尾に、「英単語を参照しているファイル」として単語を含むファイルの一覧が表示されます。

Jテキスト(和文テキスト)

拡張子.textのファイルはJテキスト形式のファイルとして開きます。

Jテキストは、ブラウザで閲覧する文書の作成を目的とした形式です。PDF出力やプリントアウトにも対応します。

テキスト主体のWEBページの作成に用いることもできます。


Jテキストでは、各種のドキュメント/説明書/技術文書/論文/小説/原稿/簡単なちらしなど、テキスト主体でシンプルなレイアウトの文書を記述するための基本的な文字の装飾や行のスタイルの指定に対応します。

スタイルの指定は、下記の簡単な記号を入力するだけで完了します。画面にも即時に反映されます。

文字と段落のスタイル

見出し
行頭が.....................で始まる段落を、見出し1〜6で表示します。
見出しのスタイルはフォント/サイズ/行取り/左揃え/中央揃え/右揃え/装飾/色/上下左右のパディング・枠・マージン/オプションと、出力の際に行頭の記号も出力する/しないを指定できます。
行頭に指定する記号の種類はカスタマイズできます。
文字スタイル1〜9
【】〔〕{}『』[]〈〉で括られた文字列を、文字スタイル1〜6で表示します。デフォルトは、
太字下線色分け+太字/『色分け+太字』/[色分け+太字]/表示なしです。
スタイルはフォント/サイズ/装飾/色/オプションと、出力の際に括弧記号も出力する/しないを指定できます。
括弧で括られた文字列にルビなどの記号を指定しても、タグではなく通常文字の扱いとなります。
括弧の記号の種類はカスタマイズできます。
文字装飾
太字/下線/斜体/上付き/下付きを開始/終了する記号を『設定ダイアログ:スタイル:文字装飾』で指定すると、利用できます。
段落スタイル1〜6
行頭が1:6:で始まる段落を、段落スタイル1〜6で表示します。
スタイルは字下げ/字上げ/フォント/サイズ/左揃え/中央揃え/右揃え/装飾/色/オプションと、出力の際に行頭の記号も出力する/しないを指定できます。
行頭に指定する記号の種類はカスタマイズできます。
段落ブロック
```ブロックIDの行から、```までの行に挟まれた段落を、ブロックIDの段落として扱います。ブロックIDが「P1」〜「P6」の段落は、段落スタイル1〜6として扱います。ブロックIDが「REM」の段落は、HTMLに出力しないコメントとみなします。その他のブロックIDを指定すると、ブラウザ上でグラフなどを表示できます。詳細は後記します。
段落ブロック内では箇条書きや表など、他の段落スタイルは無効となります。
段落ブロック内のタブは、通常のタブ文字としての扱いとなります。
段落ブロックの直前の行が引用の場合は、HTML出力を実行すると段落ブロックも引用となります。HTMLプレビューでは引用の表示はされません。
段落ブロックの機能はONに固定でカスタマイズはできません。
ルビ
|親文字《ルビ》をルビとして表示します。親文字の文字種が漢字だけなど1種類の場合記号は省略できます。青空文庫と同一の形式です。ルビは、入力してから表示に反映されるまでに数秒の時間がかかります。
ルビを表す記号は固定でカスタマイズはできません。
リンク
|リンク文字列《`リンク先》をリンクとして表示します。ルビとは異なり記号は省略できません。
リンクを表す記号は固定でカスタマイズはできません。
イメージ
"イメージファイル名"の画像を1つの大きな文字として文章内に表示します。
この機能のON/OFFはカスタマイズできます。
箇条書き
行頭の1.は「箇条書き」として表示します。
箇条書きの認識のON/OFFはカスタマイズできます。
定義リスト
見出しと説明をタブで区切ると、「定義リスト」として表示します。
この機能はONに固定でカスタマイズはできません。
脚注
HTML形式[^数字]の脚注を使用できます。
脚注の認識のON/OFFや記号はカスタマイズできます。
引用
行頭のタブは「引用」として表示します。複数のタブは、引用のネストとなります。
この機能はONに固定でカスタマイズはできません。
項目をタブで区切ると、「表」として表示します。
項目が2つだけの場合は、「定義リスト」となります。
この機能はONに固定でカスタマイズはできません。
空行
段落と段落の区切りとなります。区切りの前後は、〜</p><p>〜として区切られます。
この機能はONに固定でカスタマイズはできません。
段落内改行
Shift+Enter]で段落内改行を挿入します。段落の途中で改行する場合に用います。
この機能はONに固定でカスタマイズはできません。
改段
`<text:cfz>`を入力すると、その行から段を改めます。
「印刷出力」「印刷プレビュー」の対応となります。「HTML出力」「HTML出力のプレビュー」には無効となります。
この機能はONに固定でカスタマイズはできません。
段組み指定
`<text:clm1>``<text:clm2>``<text:clm3>`を入力すると、その箇所からそれぞれ1段組み、2段組み、3段組みとなります。
「HTML出力」「印刷出力」「印刷プレビュー」の対応となります。「HTML出力のプレビュー」表示は1段組み表示となります。
この機能はONに固定でカスタマイズはできません。
HTMLタグの埋め込み
`<tag>....</tag>`のようにHTMLタグの前後に`を付けるとそのままHTMLへ出力します。改行を含んでいても構いません。複数行にまたがる長いHTMLも埋め込めます。
この機能はONに固定でカスタマイズはできません。

CSSスタイルシートとプレビュー編集

HTML出力にはCSSスタイルシートを指定できますので、ブラウザで見栄えのする文書を表示できます。指定をするには、『設定ダイアログ:スタイル:CSSの埋め込み出力』をONにして、『CSSファイル』でスタイルシートファイルを指定します。

CSSファイル』にを指定すると、WZの設定ダイアログで指定した「スタイル」「文字スタイル」「段落スタイル」「見出しスタイル」をCSSに変換してHTML出力に埋め込みます。


WZ10ではHTML出力のプレビュー編集に対応していますので、ブラウザの表示に近い画面で編集作業ができます。『表示メニュー:CSS詳細表示』をONにすると、『CSSファイル』で指定されているスタイルで編集画面を表示します。

CSSファイル』がの場合は、WZの設定ダイアログの各スタイルで指定した表示をおこないます。


HTMLプレビュー表示で印刷やPDF出力を実行すると、CSSスタイルを適用した体裁で印刷やPDFに出力することができます。

段落ブロックによるグラフ/シーケンス図/波形の表示

段落ブロックのブロックIDにmermaidplantumlwavedromを指定すると、HTML出力にグラフ、シーケンス、波形の描画を指定できます。

描画内容を指定する方法は、それぞれの言語の関連サイトをご参照ください。


本ソフトウェアの編集画面上では、グラフ、シーケンス、波形の表示には対応しておりません。また、ブラウザによっては正常に表示されない場合があります。

Web上のサービスを使用しています。サービスのURL等が変更された場合は機能が使用できなくなります。

グラフの例

```mermaid

graph LR

A-->B

```

シーケンス図の例

```plantuml

A -> B : メッセージ

A <-- B

```

波形の例

```wavedrom

{ signal: [

{ name: "clk", wave: "p.....|..." },

{ name: "Request", wave: "0.1..0|1.0" },

]}

```

その他のブロックID

将来の拡張用として予約されています。

現状でその他のブロックIDを指定すると、ブロックの全体を<pre>〜</pre>で括って出力します。

設定の埋め込み

Jテキストでは、文書の文字数や行数などを指定する「表示設定」と「印刷設定」、文書の形式を指定する「ファイル設定」、テキストの文字コードと改行コードは、テキストファイルに埋め込みとなります。

原稿を受け渡す場合にJテキストを使用すると、相手先のWZ10でもファイルを開くと文書を作成した環境とほぼ同じフォーマットで表示や編集がおこなえます。文字コードと改行コードもテキストファイルに埋め込まれた情報から読み取りますので、文字化けが発生することもありません。


拡張子.textのテキストのファイル設定に「青空文庫テキスト」など「Jテキスト」以外の設定を適用した場合、そのファイルは今後は「青空文庫テキスト」として開かれます。

拡張子.textのテキストは、デフォルトでは「Jテキスト」となりますが、別の形式のテキストを扱うことも可能です。


拡張子.textのテキストファイルには、下記の書式でヘッダが埋め込まれます。ヘッダには設定や文書のタイトルや作成者などの「メタデータ」が格納されます。

Jテキストファイルの構造
text-header: 1.0
ヘッダ行
空行
本文行

Jテキストの経緯

WZ Editorではテキスト形式による、文字や段落のスタイル/体裁を整えた文書作成の模索をしてきました。

WZ10のJテキスト(和文テキスト)は、その集大成として一区切りの完成を見たテキストファイル形式となります。

WZ3(1997年)
装飾・体裁付きテキスト文書
WZ文書(バイナリファイル)
WZ4(1999年)
TML文書(半バイナリファイル)
WZ6(2008年)
体裁文書
WZ7(2010年)
WZ標準テキスト(JISテキスト)
青空文庫テキスト
WZ8(2013年)
JISテキスト
WZ Markdown Editor(2017年)
マークダウンテキスト
WZ10(2018年)
Jテキスト

青空文庫

先頭付近に「テキスト中に現れる記号について」を含む文書を青空文庫形式として開きます。

WZ10では、「青空文庫形式」のルビや注釈を含むテキストファイルに対応しています。


既存の開いたファイルを手動で青空文庫形式に設定するには、下記の操作をおこないます。

  1. ファイルメニュー:ファイル設定の一覧』を実行
  2. 「ファイル設定の一覧」から青空文庫テキストを選択してOK


青空文庫形式の文書を新規に作成するには、下記の操作をおこないます。

  1. ファイルメニュー:新規作成ダイアログ』を実行
  2. 青空文庫テキストを選択してOK

青空文庫の文字装飾

青空文庫テキストの文字装飾は、傍点、傍線、ゴシック太字、斜体、文字サイズ、上付き、下付きに対応しています。文字装飾を指定すると、青空文庫規定の[#傍点]〜[#傍点終わり]などのタグを挿入します。

ルビ

青空文庫形式によるルビは、文中でルビで括って表現します。

(例)漢字《かんじ》 → 漢字かんじ

ルビの付く文字列の始まりを特定する記号|が付くことがあります。

(例)漢|字《じ》 → 漢

青空文庫形式による注釈は、「JIS第3水準の漢字」と「傍点の位置指定」に対応しています。

ルビを付けるには、漢字を選択、『挿入メニュー:ルビ』を実行、「ルビ」を入力してOKします。

傍点

傍点を指定するには、下記の操作をおこないます。

  1. 傍点を付ける文字列を選択
  2. 挿入メニュー:タグ』を実行
  3. 傍点』の「傍点」「白ゴマ傍点」「白丸傍点」「丸傍傍点」「黒三角傍点」「白三角傍点」「二重丸傍点」「蛇の目傍点」から選択してOK

蛇の目傍点は、○と小さい●を重ね合わせて表示するため、表示がずれる場合があります。

傍線

傍線を指定するには、下記の操作をおこないます。

  1. 傍線を付ける文字列を選択
  2. 挿入メニュー:タグ』を実行
  3. 傍線』の「傍線」「二重傍線」「破線」「鎖線」「波線」から選択してOK

縦書きでは文字の右側、横書きでは下側に線を表示します。

波線は二重破線で代替表示します。

太字、斜体、上付き、下付き

「ゴシック太字」「斜体」「上付き」「下付き」の文字装飾は、下記の操作をおこないます。

  1. 装飾する文字列を選択
  2. 挿入メニュー:タグ』を実行
  3. 「ゴシック太字」「斜体」「上付き」「下付き」を選択してOK

「ゴシック太字」は「MSゴシック」フォントの表示となります。

文字サイズ

文字サイズを指定するには、下記の操作をおこないます。

  1. 文字サイズを変更する文字列を選択
  2. 挿入メニュー:タグ』を実行
  3. 「大きく」または「小さく」を選択
  4. サイズ変更の段階を1〜15から選択してOK

ブロックの装飾

ブロックの装飾は、複数の段落のゴシック太字・斜体・文字サイズの装飾を一括して指定する機能です。装飾を指定すると、青空文庫規定の[#ここから太字]〜[#ここで太字終わり]などのタグを挿入します。ゴシック太字は、「MSゴシック」フォントの表示となります。

ブロックの装飾を指定するには、下記の操作をおこないます。

  1. 装飾する段落を選択
  2. .『挿入メニュー:タグ』を実行
  3. 「ブロック体裁」を選択
  4. 「ゴシック太字」「斜体」「大きく」「小さく」を選択してOK
  5. 文字サイズの指定は、サイズ変更の段階を1〜15から選択してOK

ブロックの装飾を指定してから段落のテキストを入力するには、下記の操作をおこないます。

  1. 選択を解除
  2. 挿入メニュー:タグ』を実行
  3. 「ブロック体裁」を選択
  4. 「ゴシック太字」「斜体」「大きく」「小さく」を選択してOK
  5. 文字サイズの指定は、サイズ変更の段階を1〜15から選択してOK

続けて段落を入力すると、装飾表示がおこなわれます。

青空文庫の段落体裁

WZ9では青空文庫の規定の注記による字下げ、地寄せ、地付き、字詰め、箇条書き、改ページ、改段の指定に対応しています。WZ9の拡張機能として、n/m改行と行間の指定にも対応します。

字下げ

字下げを指定するには、下記の操作をおこないます。

  1. 字下げする段落を選択
  2. 挿入メニュー:タグ』を実行
  3. 「字下げ」を選択
  4. 字下げ文字数を1〜15から選択
  5. 「折り返しの字下げ」に「指定なし」を選択してOK

段落の前後に[#ここから○字下げ]と[#ここで字下げ終わり]タグの行が挿入されて、段落が字下げ表示されます。タグの表示をOFFにすると、タグ行の表示は消えて本文だけの表示となります。

タグを削除すると、字下げは解除されます。

「折り返しの字下げ」に0〜14を選択すると、段落の折り返し行の字下げを指定できます。

地寄せ・地付き

地寄せ・地付きを指定するには、下記の操作をおこないます。

  1. 地寄せする段落を選択
  2. 挿入メニュー:タグ』を実行
  3. 「地寄せ」を選択
  4. 「地付き」か地寄せ文字数を1〜14から選択してOK

段落の前後に[#ここから地から○字上げ]と[#ここで字上げ終わり]タグが挿入され、段落が行末寄せで指定した文字数の字上げで表示されます。

字詰め

字詰めを指定するには、下記の操作をおこないます。

  1. 字詰めする段落を選択
  2. 挿入メニュー:タグ』を実行
  3. 「字詰め」を選択
  4. 字詰め文字数を1〜60から選択してOK

段落の前後に[#ここから○字詰め]と、[#ここで字詰め終わり]のタグが挿入されて、指定した文字数で段落を折り返して表示します。

字詰めの指定は、字下げの指定と併用できます。4字下げて、30字詰めなどの指定がおこなえます。

字詰めと字下げを指定するには、下記の操作をおこないます。

  1. 対象とする段落を選択
  2. 挿入メニュー:タグ』を実行
  3. 「字下げ」を選択
  4. 字下げ文字数を1〜15から選択し、「折り返しの字下げ」に「指定なし」を選択してOK
  5. 挿入メニュー:タグ』を実行
  6. 「字詰め」を選択
  7. 字詰め文字数を1〜60から選択してOK

このほか、ゴシック太字、斜体、文字サイズの併用指定に対応しています。

箇条書き

折り返しの字下げと記号を組み合わせた箇条書きの指定に対応しています。

  1. 箇条書き指定をする段落を選択
  2. 挿入メニュー:タグ』を実行
  3. 「箇条書き」を選択
  4. 箇条書きの記号を「・」「1.」「一、」から選択してOK

段落の先頭に指定した箇条書き記号が挿入され、段落の前後に[#ここから0字下げ、折り返して○字下げ]と[#ここで字下げ終わり]タグの行が挿入されて、段落が箇条書きの字下げで表示されます。

図はテキストに大きな1つの文字の扱いとして挿入表示されます。

下記の操作で図を挿入できます。

  1. 挿入メニュー:図』を実行
  2. ファイル名を指定してOK

カーソル位置に、[#図(ファイル名)入る]のタグが挿入されて、画像が表示されます。

n/m改行と行間

n/m改行と行間は、段落単位の改行の高さや行間を指定する機能です。

空行の空きを詰めたり、行間を1/2や0に詰めて表示します。

下記の操作でn/m改行を指定すると、段落先頭にタグが挿入されて、行高を1/3,1/2,2/3行で表示します。

  1. 挿入メニュー:タグ』を実行
  2. 一覧から「改行高さ」を選択
  3. 「1/3」「1/2」「2/3」から選択してOK

段落を通常の行高に戻すには、タグを削除します。

下記の操作でn/m行間を指定すると、段落先頭にタグが挿入されて、行間を1/2や0で表示します。

  1. 挿入メニュー:タグ』を実行
  2. 一覧から「行間」を選択
  3. 「0」「1/2」から選択してOK

段落を通常の行高に戻すには、タグを削除します。

参考:n/m改行と行間は青空文庫に規定のない、WZの拡張タグです。

改ページ

改ページは指定箇所でページを改めて、続きを次のページから印刷する機能です。

改ページを挿入するには、下記の操作をおこないます。

  1. 挿入メニュー:改ページ/改段文字』を実行
  2. 一覧から改ページを選択してOK

改段

改段は指定箇所で段組を改めて、続きを次の段から印刷する機能です。

改段を挿入するには、下記の操作をおこないます。

  1. 挿入メニュー:改ページ/改段文字』を実行
  2. 一覧から改段を選択してOK

タグ

青空文庫テキストでは、『挿入メニュー:タグ』を実行すると文字装飾や段落体裁を指定できます。この章ではタグの概要について説明します。

青空文庫形式では、ルビや文字装飾は専用の記号をテキスト本文の中に埋め込んで指定します。この記号を青空文庫では「注記」、WZでは「タグ」と呼びます。青空文庫では下記のタグを使用します。

ルビの指定
  
文字装飾・段落体裁
#各種文字列
各種文字列には全角文字で装飾や体裁を指定します。

WZ10では、青空文庫規定の下記の文字装飾と段落体裁の表示に対応しています。

漢字《読み》
漢字に読みのルビ付きで表示します。
漢字|漢字《読み》
漢字に読みのルビ付きで表示します。
|記号はルビを付ける位置を指定します。
#傍点]〜[#傍点終わり
タグで括られた文字列を傍点付きで表示します。
白ゴマ、丸、白丸、黒三角、白三角、二重丸、蛇の目傍点にも対応します。
#傍線]〜[#傍線終わり
文字列を傍線付きで表示します。
二重傍線、鎖線、破線、波線にも対応します。
波線は二重破線の代替表示となります。
#太字]〜[#太字終わり
文字列をゴシック太字で表示します。
#斜体]〜[#斜体終わり
文字列を斜体で表示します。
#上付き小文字]〜[#上付き小文字終わり
文字列を上付きの小さい文字で表示します。
#下付き小文字]〜[#下付き小文字終わり
文字列を下付きの小さい文字で表示します。
#改ページ
以降の段落から改ページします。
#改段
以降の段落から改段します。
#ここから太字]〜[#ここで太字終わり
タグに挟まれた段落ブロックをゴシック太字表示します。
#ここから斜体]〜[#ここで斜体終わり
段落ブロックを斜体表示します。
#ここから○字下げ]〜[#ここで字下げ終わり
段落ブロックを字下げ表示します。
字下げ数は全角の数字で指定します。
#ここから○字下げ、折り返して●字下げ]〜[#ここで字下げ終わり
段落ブロックを凹凸の字下げ表示します。
字下げ数は全角の数字で指定します。
#ここから地付き]〜[#ここで地付き終わり
段落ブロックを地付き(行末揃え)表示します。
#ここから地から○字上げ]〜[#ここで字上げ終わり
段落ブロックを地付きの字上げ表示します。
字上げ数は全角の数字で指定します。
#ここから○字詰め]〜[#ここで字詰め終わり
段落ブロックを指定の字詰めで表示します。
字詰め数は全角の数字で指定します。
#「文字列」に傍点
文字列を傍点付きで表示します。
丸、白丸、黒三角、白三角、二重丸、蛇の目傍点にも対応します。
#「文字列」に傍線
文字列を傍線付きで表示します。二重傍線にも対応します。

JISテキスト

先頭付近に_‖.tag.jis‖_を含む文書をJISテキストとして開きます。

WZ10では、「JIS形式」のルビや注釈を含むテキストファイルに対応しています。


任意のファイルをJISテキストとして開き直すには、下記の操作をおこないます。

  1. ファイルメニュー:ファイル設定の一覧』を実行
  2. 「ファイル設定の一覧」からJISテキストを選択してOK

ルビ

JISテキストでルビを入力するには、下記の操作をおこないます。

  1. 挿入メニュー:ルビ』を実行
  2. 読み漢字を入力してOK

下記の記号と文字が挿入され、ルビが表示されます。

_^漢字(よみ)^_


ルビを編集するには、下記の操作をおこないます。

  1. ルビにカーソルを移動
  2. Alt+Enter]を押す
  3. 読み漢字を編集してOK

文字装飾

JISテキストの文字装飾は、傍点、傍線、上付き、下付きに対応しています。WZの拡張タグによる太字、文字スタイル(文字サイズ)にも対応しています。文書にコメントを埋め込む割注タグの使用も可能です。

傍点

傍点を指定するには、下記の操作をおこないます。

  1. 傍点を付ける文字列を選択
  2. 挿入メニュー:タグ』を実行
  3. 傍点を選択してOK

傍線

傍線を指定するには、下記の操作をおこないます。

  1. 傍線を付ける文字列を選択
  2. 挿入メニュー:タグ』を実行
  3. 下線を選択してOK

縦書きでは文字の右側、横書きでは下側に傍線を表示します。

上付き、下付き

上付き、下付きを指定するには、下記の操作をおこないます。

  1. 装飾する文字列を選択
  2. 挿入メニュー:タグ』を実行
  3. 上付き下付きを選択してOK

太字

太字を指定するには、下記の操作をおこないます。

  1. 装飾する文字列を選択
  2. 挿入メニュー:タグ』を実行
  3. 太字を選択してOK
参考
太字装飾はJISの規定がないので、WZの独自のタグ_※太字※_を挿入します。

文字スタイル

文字スタイルは、フォント、フォントサイズ、下線などの文字装飾のスタイルを6種類登録して、スタイル別に表示を揃える機能です。

文字スタイルを指定するには、下記の操作をおこないます。

  1. 装飾する文字列を選択
  2. 挿入メニュー:タグ』を実行
  3. 文字スタイル1〜6を選択してOK

文字スタイルの装飾表示を指定するには、下記の操作をおこないます。

  1. 文字スタイル装飾の文章にカーソルを移動
  2. Alt+Enter]を押す
  3. フォントフォントサイズ下線太字を指定してOK
参考
文字スタイルはJISの規定がないので、WZの独自のタグ_※《《1》》装飾※__※《《6》》装飾※_を挿入します。

割注

割注は、文章の中にコメントを埋め込む機能です。

割注を入力するには、下記の操作をおこないます。

  1. 表示メニュー:タグの全表示』をON
  2. 挿入メニュー:タグ』を実行
  3. 割注を選択してOK
    カーソル位置に、_‖‖_が挿入されます。
  4. 続けて割注を入力
    割注は「改行」「段落内改行」には対応していません。

割注を削除するには、下記の操作をおこないます。一箇所ずつ確認しながら削除できます。

  1. 検索メニュー:置換』を実行
  2. 正規を選択
  3. 検索に下記を指定
    _‖.*‖_
  4. 置換を空に設定
  5. 置換の確認』をONにして、OK

タグ

JISテキストでは、『挿入メニュー:タグ』を実行すると文字装飾や段落体裁を指定できます。

JIS形式では、ルビや文字装飾は専用の記号をテキスト本文の中に埋め込んで指定します。この記号をWZでは「タグ」と呼びます。

タグとして認識される記号を、本文で使用するにはタグの前に\を挿入します。\に続くタグの記号は、装飾や体裁の指定が取り消されます。タグの表示をOFFにすると、挿入した\は消去されてタグの記号が表示されます。\自身は\\で表します。

JISテキストのタグの一覧

_^親文字(ルビ)^_
ルビを指定します。
_^親文字【ルビ】^_
JISで許容されたルビの指定です。
_^親文字/ルビ^_
JISで許容されたルビの指定です。
_^親文字{ルビ}^_
JISで許容されたルビの指定です。
_¨傍点をふる文字列¨_
傍点を指定します。
_¨≪≪◎≫≫傍点をふる文字列¨_
傍点の記号○●▲△◎を指定します。
_ ̄アンダーライン/傍線 ̄_
横書きはアンダーライン、縦書きは傍線となります。
_‖割注‖_
文章に注を埋め込みます。
¶《《改頁》》
ここから改ページします。
¶《《改段》》
ここから改段します。
_↑上付き↑_
フォントサイズ1/2で上半分に表示します。
_↓下付き↓_
フォントサイズ1/2で下半分に表示します。
_/縦中横/_
タグの認識と色分けを表示します。
_⊥和字扱い⊥_
タグの認識と色分けを表示します。
_※太字※_
太字を指定します。
_※《《1》》装飾1※_
文字装飾1でフォント・太字・下線を一括指定します。
_※《《2》》装飾2※_
文字装飾2でフォント・太字・下線を一括指定します。
_※《《3》》装飾3※_
文字装飾3でフォント・太字・下線を一括指定します。
_※《《4》》装飾4※_
文字装飾4でフォント・太字・下線を一括指定します。
_※《《5》》装飾5※_
文字装飾5でフォント・太字・下線を一括指定します。
_※《《6》》装飾6※_
文字装飾6でフォント・太字・下線を一括指定します。
¶《《8/9改行》》
行高を90%とします。段落先頭に指定します。
¶《《4/5改行》》
行高を80%とします。段落先頭に指定します。
¶《《3/4改行》》
行高を75%とします。段落先頭に指定します。
¶《《2/3改行》》
行高を66%とします。段落先頭に指定します。
¶《《1/2改行》》
行高を50%とします。段落先頭に指定します。
¶《《1/3改行》》
行高を33%とします。段落先頭に指定します。
¶《《1/4改行》》
行高を25%とします。段落先頭に指定します。

はJISで規定されていないWZ独自のタグ指定です。

PDF Book

.pdfファイルは、WZが作成した「PDF Book」の場合は、本文テキストの編集モードとなります。その他の.pdfファイルはバイナリファイルとして開きます。


PDF Bookは、PDFの出力イメージに加えて本文テキスト、WZの設定、表紙、序文、目次、索引、奥付、図を埋め込んだPDFファイルです。

PDF Bookの作成

PDF Bookを作成するには、「テキストファイルから作成」「新規作成」「PDF Bookから作成」の3通りあります。

付属する表紙などの入力

PDF Bookでは、本文テキストと独立して、表紙、序文、目次、索引、奥付、備忘録テキストを入力できます。

表紙〜備忘録の各部位のテキストを入力するには、『ツールメニュー:専用メニュー』を実行して「専用メニュー」から切り替えます。備忘録には、印刷に出力しないアイデアやメモなどを入力して保存しておけます。

設定

PDF Bookでは、本文テキストと独立して表紙、序文、目次、索引、奥付の個別に表示/印刷の設定が可能です。備忘録は本文テキストの設定と共通となります。ファイル設定は本文と表紙〜備忘録ですべて共通となります。

表示メニュー:設定』を実行すると、設定ダイアログのタイトルバーに「設定 - 目次」のように設定対象の部位を表示します。


PDF Bookの設定ダイアログは、WZ独自のプロパティシートとなります。

本文テキスト以外の部位では、表示・印刷の設定はすべて「専用設定」となります。「設定/カテゴリ順」のダイアログでスタイルを切り替えると専用設定を置き換えます。

スタイルの設定内容を表示〜奥付で揃えるには、「設定/カテゴリ順」ダイアログの目次でスタイル名をクリック、「表紙〜奥付で共通化」をクリックします。

スタイルの設定内容を項目単位で揃えるには、設定ダイアログで設定項目をクリック、「項目メニュー」をクリック、「表紙〜奥付で共通化」をクリックします。

図の挿入

図をテキストに埋め込むには、「図のファイル名の入力」「クリップボードから貼り付け」の2通りあります。

図のファイル名の入力は、『挿入メニュー:図』を実行、イメージファイルを指定、OKします。WZからPDF出力を実行すると、図はPDFファイルに埋め込み(添付)されます。


クリップボードから貼り付けるには、「ペイント」などのアプリケーションで図をクリップボードにコピーしてからWZで『編集メニュー:貼り付け』を実行します。図はWZで編集中のPDFファイルに添付され、テキストには".0252613000.img"のような図のIDが埋め込まれます。図のIDをテキストの別の箇所に入力すると、同じ図をその箇所に表示します。

図の"ファイル名"の表示は、『表示メニュー:タグの全表示』でON/OFFできます。

PDFに挿入した図は、クリップボードにコピーして他のアプリケーションで表示することができます。図をコピーするには、図にカーソルを合わせて『編集メニュー:コピー』を実行します。

図の一覧

PDF Bookに埋め込まれている図の一覧を表示するには、『ツールメニュー:専用メニュー』を実行、『図版の一覧』を実行します。「図版の一覧」ダイアログが開いて、図版の一覧とプレビューを表示します。ダイアログでは、下記の図版のメンテナンスがおこなえます。

削除
一覧で選択した図を削除します。
図版が文書で使用されている場合は、「削除しない」がデフォルトの問い合わせをします。
図版が文書で使用されていない場合は、「削除する」がデフォルトの問い合わせをします。
コピー
一覧で選択した図をクリップボードにコピーします。
プロパティ
一覧で選択した図のサイズ、グレイスケール/フルカラーを表示します。

目次の自動作成

本文テキストの見出しの段落に、見出し記号(WZアウトラインの行頭の半角ピリオドなど)を付けておくと、見出し段落を抽出して自動で目次を作成できます。目次を作成するには、『ツールメニュー:専用メニュー』を実行、『目次の更新』を実行します。


目次を設定するには、『表示メニュー:設定』を実行、目次から「アウトライン―目次の自動作成」を選択、各項目を設定します。

印刷プレビューから「目次の更新」を実行すると、印刷のページ番号を出力します。

索引の自動作成

本文テキストをWZ内蔵の日本語辞書により解析して、索引を自動で作成できます。索引を作成するには、『ツールメニュー:専用メニュー』を実行、『索引の自動作成』を実行します。索引の作成には数分かかる場合があります。

作成された索引を編集して、不用な語句の削除、ア行〜ワ行の読みの間違いの訂正、足りない語句を追加します。


索引の自動作成をしておくと、次回からは『専用メニュー:索引の更新』の実行で、索引のページ番号を自動更新します。

索引のページ番号は、印刷プレビューで実行すると印刷のページ番号、通常編集で実行すると行番号となります。

本文テキストの追加・訂正によって索引に語句を追加するには、『ツールメニュー:専用メニュー:索引』を実行して索引編集に切り替えて、語句タブの段落を追加します。

脚本

.scrファイルは脚本テキストとして開きます。

WZでは脚本やシナリオの編集に向けた、原稿用紙表示、柱のアウトライン表示、ト書きの字下げ、会話文の認識に対応しています。


脚本テキストを新規に作成するには、『ファイルメニュー:新規作成ダイアログ』を実行、脚本を選択してOKします。


脚本テキストは、下記の表示が適用されます。

柱は、行頭が○で始まる場面名を表す段落です。○の他に、●◎□■△▲が指定できます。


会話文認識は、人物名「せりふ」形式の段落を認識して、「人物名」と「せりふ」を別のフォントで表示する機能です。

柱と会話文以外の段落は、「ト書き」で全角2文字の字下げが適用されます。

字下げ数は、『設定ダイアログ:スタイル:本文のスタイル:字下げ』で指定できます。

体裁文書

.txzファイルは体裁文書テキストとして開きます。

「体裁文書」はWZ6の「ルビ」「文字装飾」「段落体裁」に対応したテキストファイル形式です。

体裁文書ではテキストタグを<.英単語>と<./英単語>で表記します。

WZ10では、「ルビ」のテキストタグの指定は廃止されました。

TML文書

.tmlファイルはTML文書として開きます。

「TML文書」は、WZ5/WZ4の「ルビ」「文字装飾」「段落体裁」に対応したテキストファイル形式です。


WZ10では互換機能でTMLの見出し・字下げ・ルビ・太字・下線・斜体・上付き・下付きを認識してテキストを表示します。TML文書では、「タグの表示」をOFFにすると、「桁揃え」を認識して表示に反映します。

ルビ

ルビにカーソルを移動して、『編集メニュー:プロパティ』を実行すると、ルビを編集できます。

タグの挿入

挿入メニュー:タグ』から、ルビ/太字/下線/斜体/上付き/下付きの文字装飾がおこなえます。

TMLファイルの変換

「TMLファイル」を「Jテキスト」「JISテキスト」「体裁文書」「HTML」に変換して引き継げます。脚注/中央揃え/右揃え/傍点/図の一部の引き継ぎにも対応しています。

TMLファイルをJISテキストに変換するには、下記の操作をおこないます。

  1. TMLファイルを開く
  2. ツールメニュー:テキストの変換』を実行
  3. TMLテキストをWZ標準テキストにを選択
  4. ファイルメニュー:新規作成ダイアログ』からJISテキストを新規作成
  5. 編集メニュー:貼り付け』を実行。変換結果が貼り付けられます

タブ区切りテキスト(TSV)

tsvファイルは、タブ区切りテキストとして開きます。

タブの位置で前後の段落の桁を揃えて、罫線のない表の形式で表示します。

表形式の段落の折り返しは「なし」となります。

項目を編集すると、桁の幅を自動で再計算して表示を更新します。

TSVとして編集

任意のファイルのタブ区切りのデータを編集するには、下記の操作をおこないます。

  1. ファイルを開く
  2. ファイルメニュー:ファイル設定の一覧』を実行
  3. タブ区切りテキストを選択してOK

タブ区切りのデータは、桁揃えで表示されます。

CSVテキスト

.csvファイルは、カンマ区切りテキストとして開きます。

半角のカンマ区切りのデータを、カンマの位置で前後の段落の桁を揃えて、罫線のない表の形式で表示します。

表形式の段落の折り返しは「なし」となります。

"..."内のカンマは区切り記号ではなく、データとみなします。

CSVとして編集

任意のファイルのカンマ区切りのデータを編集するには、下記の操作をおこないます。

  1. ファイルを開く
  2. ファイルメニュー:ファイル設定の一覧』を実行
  3. CSVテキストを選択してOK

半角のカンマ区切りのデータは、桁揃で表示されます。

マークダウンテキスト

.mdファイルは、マークダウンテキストとして開きます。

WZ10.0.9以降

WZ10.0.9以降では、マークダウンテキストは「プレーンテキスト」として開くように仕様が変更となりました。マークダウン専用の編集機能はOFFとなり、マークダウンの######による見出しの認識のみに対応します。

マークダウン編集機能をONにするには、下記の設定をおこないます。

この設定をおこなうと、下記のWZ10.0.8以前と同一のマークダウン機能が有効となります。

WZ10.0.0〜WZ10.0.8

マークダウン専用の編集と見出しの認識に対応します。たとえば[Enter]で改行すると、空白2つの追加等が実行されます。

WZ Markdown Editorとは下記を除いて同一の仕様です。詳細は、こちらをご参照ください。

HTML

.htm.html.shtml.xml.xhtmlファイルは、「HTMLテキスト」として開きます。

色分け表示は、<!--コメント-->/*コメント*/// コメント"文字列"数値#16進数の数値、HTMLのタグと属性、URL、検索文字列に対応します。


アウトラインメニュー:アウトライン』を実行すると、編集領域の右側のアウトラインに、HTMLの<h1><h6>の見出しの一覧を表示します。


HTMLテキストでは、タグのスマート入力、タグの選択入力、タグのアトリビュート編集、CSSプロパティ入力と編集、タグの表示のON/OFF、文字参照の置き換え表示、HTMLタグとCSSプロパティの補完入力、Zen-coding/Emmetによる省略記法に対応しています。


WZで編集中のHTMLテキストをブラウザで開いてレイアウトの表示を確認するには、『ファイルメニュー:上書き保存』を実行、『ファイルメニュー:関連付けプログラムで開く』を実行します。

専用キー操作

HTMLファイルを開くと、専用のキー操作が有効となります。

Shift+Enter
カーソル位置に<br>と改行を挿入
Alt+Enter
カーソル位置のタグや、スタイルシートのプロパティを編集するダイアログを表示

「VZライク」キー定義では、『ヘルプメニュー:スマートコマンド』からLFFコマンドを実行します。

Ctrl+Enter]の操作

WZ10の標準では、[Ctrl+Enter]で、Zen-coding/EmmetによるHTMLタグまたはCSSプロパティの展開が実行されます。


WZ9までの[Ctrl+Enter]で「カーソル位置のタグに応じて改段落」「補完」「オートフォーマット」を実行するには、『設定ダイアログ:インターフェース:キー:WZ10追加定義』をOFFにします。

この場合は、下記の機能が使用できるようになります。

タグ記号の補完

タグの入力後に[Ctrl+Enter]を押すと、タグ記号の > を補完します。

HTMLの要素名の入力後に[Ctrl+Enter]を押すと、<> 記号を補完します。

改段落

カーソルを<p>〜</p>の範囲内に移動して、[Ctrl+Enter]を押すと、新規に段落を作成します。

終了タグの補完

終了タグを入力する位置で[Ctrl+Enter]を押すと、補完入力します。

タグのネスティングにも対応しています。

オートフォーマット

「箇条書き」の<dl>や<ul>タグのオートフォーマットに対応しています。

Ctrl+Enter]キーを押す。

さらに[Ctrl+Enter]キーを押す。

専用メニュー

HTMLファイルでは専用のメニューコマンドが有効となります。

挿入メニュー:タグ
HTMLのタグをダイアログで選択挿入
編集]メニュー:プロパティ
タグのアトリビュートを編集するダイアログを表示
表示メニュー:文字参照を文字表示
文字参照「&lt;」「&gt;」「&amp;」「&quot;」を、文字「<」「>」「&」「"」として表示(文章の内容は保ちます)
表示メニュー:タグの全表示
HTMLタグの表示をON/OFF
表示メニュー:タグの記号表示
HTMLタグを1文字の記号で表示
アウトラインメニュー:タグアウトライン
タグの入れ子関係をアウトラインに表示
xmlとxhtmlファイルに対応
検索メニュー:対括弧
対応する開始タグや終了タグへジャンプ

スマート入力

HTMLファイルのスマート入力では、HTMLタグとCSSアトリビュートの補完入力が有効となります。

IMEをONにした日本語入力モードに対応していますので、IMEの切り替え操作なしで、識別子やHTMLタグの補完入力がおこなえます。


スマート入力モードのON/OFFを切り替えるには、『挿入メニュー:スマート入力モード』を実行します。

スマート入力モードをONにすると、ステータスバーの左側に[R]と表示します。

編集テキストに加えて、『設定ダイアログ:入力:単語補完辞書1〜4』で指定したファイルからも入力候補を検索します。

スタイルシート

WZでは、CSSスタイルシートのプロパティをダイアログで編集できます。HTMLファイルに加えてテキストファイルでもCSSのプロパティダイアログを利用できます。

ブラウザの独自拡張のプロパティには対応しておりません。


CSSプロパティをダイアログで編集するには、下記の操作をおこないます。

  1. スタイルシートの指定箇所へ移動
  2. Alt+Enter]を押して、ダイアログを表示
  3. ダイアログで、各プロパティを設定してOK

(例1) { または }で、[Alt+Enter]を押します。

h1 {background-color:#004080; color:#FFFFFF; text-align:left; padding:0.2em; padding-left:1ex; font-size:110%}

(例2)「style="」で、[Alt+Enter]を押します。

<div style="background-color:#004080;" align="center">

(例3)CSSの各プロパティで、[Alt+Enter]を押します。

background-color:上で[Alt+Enter]で『背景色』のプロパティの設定ダイアログが表示されます。

CSSスタイルの新規入力

CSSプロパティを新規に入力するには、下記の操作をおこないます。

  1. h1 {}style=""を入力
  2. {または}もしくは"にカーソルを移動
  3. Alt+Enter]を押してダイアログを表示
  4. ダイアログで各プロパティを設定してOK
改行区切りのプロパティ指定

CSSプロパティのダイアログ編集機能は、下記のように改行で区切ったプロパティの指定にも対応しています。

h1 {

  background-color:#004080;

  color:#FFFFFF;

}

プロパティの先頭と末尾のコメントは保存されます。その他のコメントは削除されます。

h1 {// 保存されるコメント

  background-color:#004080;// 削除されるコメント

  color:#FFFFFF;

}

Zen-coding/Emmet

WZ10では、Zen-coding/EmmetによるHTMLタグやCSSプロパティの省略入力に対応します。

タグ名、「.」クラス名、「>」ネスト、「+」並列、「*」複数展開の省略入力で複雑なHTMLタグを展開できます。


各コマンドを使用するには、『挿入メニュー:HTMLタグ』から『省略記法の展開』『タグの展開』『CSSプロパティの展開』『領域の選択』を実行します。

Ctrl+Enter]で、タグまたはCSSプロパティの展開が実行できます。


Zen-coding/Emmetについて詳しくは、WEBで検索キーワード「Emmet入門」で表示される各サイトをご覧ください。

WZの機能は、公式ドキュメントに従った独自実装となっております。一部未実装の機能や仕様が異なる点もありますのでご注意ください。

TeX

.texファイルは、TeXとして開きます。TeXファイルは、主に数式を含む理数系の論文や書籍の標準的なフォーマットです。

TeX表記によるアウトライン、数学記号や表体裁の表示、各種の編集支援機能が有効となります。スマート入力によるTeXコマンドの補完入力にも対応します。

pLaTeXとdviout

TeXファイルをコンパイルしてTeX文書の画面を表示するには、WZとは別のソフトウェア「pLaTeX」と「dviout」が必要です。このソフトウェアはインターネットからダウンロードし、フリーソフトウェアとしてインストールできます。

WZから、TeXファイルのコンパイルとdvioutのプレビューを実行することも可能です。事前に、下記の必要な操作をおこないます。


※「pTeX, Version 3.1415926-p3.1.10 (Web2C 2009)」にて動作を確認しました。

※「pLaTeX」「dviout」「BibTeX」のダウンロードやインストール、環境変数の定義、関連付けの方法などのお問い合わせにつきましては、テクニカルサポートの対象外となります。

文献データベース

文献データベースファイル(拡張子.bib)をWZで開くと、「BIB VIEW」機能が有効となります。

「BIB VIEW」を起動するには、下記の操作をおこないます。

絞り込みするには、「BIB VIEW」の「一覧」で文字を入力します。絞り込みを解除するには[BS]キーを必要な回数押すか、[表示]-[絞り込みの解除]を実行します。

「BIB VIEW」では、メニューバーから各種操作が実行できます。

ファイルメニュー:終了
BIB VIEWを終了
編集メニュー:IDのコピー
選択項目のIDの内容をクリップボードにコピー
「文献名」として\citeコマンドに指定可能
表示メニュー:表示項目の設定
一覧に表示する項目名や表示幅、順序をカスタマイズ
表示メニュー:絞込みの解除
一覧の絞り込み表示を解除
表示メニュー:題名順〜発行年順
一覧を題名順、著者順、よみ順、出版社順、発行年順でソート

キー操作

TeXファイルを開くと、専用のキー操作が有効となります。

Shift+Enter
カーソル位置に\\を挿入します。
Enter
\item段落内で改行すると、新しい行を\itemで始めます。予め『表示メニュー:タグの全表示』のOFFか、『表示メニュー:タグの記号表示』のONが必要です。
Alt+B
「TeX専用メニュー」を表示します。
コンテキストメニュー
「TeX専用メニュー」コマンドが追加されます。

メニュー操作

TeXファイルを開くと、各種のメニューコマンドが有効となります。

挿入メニュー:タグ
TeXのコマンドをダイアログから選択して挿入します。
表示メニュー:文字参照を文字表示
数学記号やギリシャ文字のコマンドを文字で表示します。
(例)\sumΣ\alphaαと表示します。
表示メニュー:タグの全表示
TeXコマンドの表示をON/OFFします。表示をONにすると、コマンドの解釈はおこないません。
表示をOFFにすると、TeXコマンドと$&を表示上で消し、数学記号とギリシャ文字を表示し、TeXコマンドの一部を解釈して、体裁を整えた表示を実行します。
表示メニュー:タグの記号表示
TeXコマンドを表示し、コマンドの一部を解釈して体裁を整えた表示を実行します。
アウトラインメニュー:タグアウトライン]
\begin{環境名}-\end{環境名}のタグの入れ子関係を、アウトラインに表示します。
ツールメニュー:専用メニュー
TeX専用メニューを表示します。

専用メニュー

TeXファイルで[Alt+B]を押すと、TeX専用のメニューを表示します。

タイプセットとプレビュー
文書を上書き保存して「pLaTeX」でTeXをコンパイルします。コンパイル結果は「ファイル名.dvi」に出力されます。ログファイル「ファイル名.log」が作成されます。ステータスバーにコンパイルの成功/失敗を表示します。
コンパイルに成功すると「dviout」でプレビューを実行します。コンパイルに失敗するとエラーメッセージを表示します。エラーメッセージから、タグジャンプでエラー箇所にジャンプします。「pLaTeXとdvioutの準備」が必要です。
BibTeXの起動
別プログラム「BibTeX」で、TeXの参照文献の処理を実行します。「pLaTeXとdvioutの準備」が必要です。
文書タイプセット
「pLaTeX」でコンパイルして結果を表示します。
プレビュー
「divout」でプレビューします。
事前に「文書タイプセット」の実行が必要です。
「pLaTeXとdvioutの準備」が必要です。
前回コマンド実行のログ
前回のタイプセットや、「BibTeX」の実行結果を表示します。エラーメッセージやログの参照ができます。
タイプセットのログ
タイプセットのログ「ファイル名.log」を表示します。
BibTeXのログ
「BibTeX」のログ「ファイル名.blg」を表示します。
begin型補完
\begin{環境名}-\end{環境名}のTeXコマンドを選択挿入します。範囲選択して実行すると選択部分を囲みます。
large型補完
{\large ...}型のTeXコマンドを選択挿入します。
範囲選択して実行すると選択部分を囲みます。
setcion型補完
\section{...}型のTeXコマンドを選択挿入します。
範囲選択して実行すると選択部分を囲みます。
maketitle型補完
\maketitle型のTeXコマンドを選択挿入します。
アクセント補完
各種アクセントのTeXコマンドを選択挿入します。
範囲選択して実行すると選択部分を囲みます。
end補完
\begin{環境名}に対応する\end{環境名}を挿入します。
環境名の変更
\begin{環境名}と\end{環境名}を変更するダイアログを表示します。
数学記号イメージ補完
数学記号のTeXコマンドを選択挿入します。
ギリシャイメージ補完
ギリシャ文字のTeXコマンドを選択挿入します。
イメージ補完モード
「イメージ補完モード」のON/OFFを切り替えます。
WZの起動時はONです。
数式モードで[;]か[:]を入力すると「数学記号」「ギリシャ文字」の補完入力ダイアログを表示します。
数式モードの判定は$...$内、\[...\]内、\begin{eqnarray}...\end{eqnarray}内で判断します。
コマンドの削除
カーソル位置のTeXコマンドを削除します。
\begin{環境名}や\end{環境名}は、対応する\begin{環境名}と\end{環境名}を削除します。
コマンドと内容の削除
カーソル位置のTeXコマンドと適用範囲の文章を削除します。\begin{環境名}や\end{環境名}は、\begin{環境名}から\end{環境名}の内容がすべて削除されます。
TeXコマンドを表示
TeXコマンドを表示します。コマンドの解釈はおこないません。
TeXコマンドを解釈して表示
TeXコマンドを表示します。TeXコマンドの一部を解釈して体裁を整えた表示を実行します。
TeXコマンドを表示しない
TeXコマンドと$&を表示上で消し、数学記号とギリシャ文字を表示し、TeXコマンドの一部を解釈して体裁を整えた表示を実行します。
数学記号とギリシャ文字の表示
数学記号やギリシャ文字の「\sum」を「Σ」、「\alpha」を「α」で表示します。
\begin-\endのアウトライン
\begin{環境名}-\end{環境名}タグの入れ子関係を、アウトラインに表示します。
設定
「pLaTeX」「BibTeX」の起動オプションを設定するダイアログを表示します。
対応ラベルへ
\ref{ラベル}、\pageref{ラベル}、\cite{文献名}に対応する、
\label{ラベル}、\bibitem{文献名}へジャンプします。

「TeXコマンド」「数学記号」「ギリシャ文字」の入力ダイアログでは、文字入力で絞り込み検索できます。

※「TeX専用メニュー」の仕様は、「p白鳥」を参考にさせていただきました。

TeXコマンドの挿入

TeXコマンドを挿入するには、下記の操作をおこないます。

テキストを範囲選択してからコマンドを実行すると、選択部分を囲みます。

行頭タブの字下げ表示

引用部分をタブで字下げして、行頭タブを字下げ表示すると視認性が向上します。

TeXコマンドの体裁表示

TeXコマンドの一部を解釈して体裁を整えた表示をするには、『表示メニュー:タグの表示』を実行して「タグの表示」をOFFにします。

段落内改行
\\コマンドを段落内改行として改行します。
上付き・下付き
指定を画面表示に反映します。Σの上下への表示やネスティング指定には対応していません。
箇条書き
\itemで始まる段落の折り返し2行目以降を字下げ表示します。
&を表のそれぞれの桁の区切りとみなして桁揃え表示します。
下記の形式の表の、桁1〜桁3を揃えて表示します。
表の仕上がりの目安を確認できます。
\begin{tabular}{|c|c|c|}
桁1a & 桁2a & 桁3a \\ <改行>
桁1b & 桁2b & 桁3b \\ <改行>
桁1c & 桁2c & 桁3c \\ <改行>
\end{tabular}

スマート入力

TeXファイルのスマート入力では、TeXコマンドと環境名の補完入力が有効となります。

スマート入力モードのON/OFFを切り替えるには、『挿入メニュー:スマート入力モード』を実行します。[Ctrl+全角/半角]でも切り替えできます。スマート入力モードをONにすると、ステータスバーの左側に[R]と表示します。

スマート入力では、WZ規定のサンプル辞書と編集テキストから補完候補を取得します。

C、C++プログラム

.c .h .cpp .txcファイルは、C、C++プログラムとして開きます。

色分け表示は、関数定義とC++のメソッド定義、/*コメント*/、// コメント、#if 0〜コメント〜#endif、プリプロセッサ、"文字列"、'文字列'、予約語、演算子、括弧、数値、0x16進数の数値、URL、検索文字列に対応します。


アウトラインメニュー:アウトライン』を実行すると、編集領域の右側のアウトラインに、編集テキストの関数名とメソッド名の一覧を見出しレベル3で表示します。

アウトラインで項目をクリックすると、関数や見出しの定義の行にジャンプします。

返り値〜関数名〜引数が1行で記述された関数やメソッドの認識に対応しています。記述が複数の行に分かれている場合など、関数定義を認識できないこともあります。

見出しレベル2には//##で始まる段落を表示します。プログラムに//##グループ名を記述すると関数をグルーピングできます。


「ブロックの折りたたみ」機能で、{}のブロックを折りたたみできます。

ブロックの開始行で[Alt+Left]にて、ブロックを折りたたみます。すでに折りたたまれている場合は、折りたたみを解除します。

関数とメソッドのドキュメント

関数やメソッドの定義の前または後方にコメントを記述すると、リファレンス機能のドキュメントとして扱います。

ドキュメントはJテキストの記法を用いて見やすく記述できます。

// ...引数

// myargには〜を指定注意点...

// ...仕様

// myargから〜を計算して結果を返す

int myapi(int myarg)

{

myarg.cに上記の記述をして保存すると、同じフォルダの他のファイルでmyapiにカーソルを合わせて[Shift][Shift]で、リファレンスに表示します。

下記のように、`/*...*/`を用いてもドキュメントを記述できます。

/*

...引数

myargには〜を指定注意点...

...仕様

myargから〜を計算して結果を返す

*/

int myapi(int myarg)

関数定義の内側でもドキュメントを記述できます。

関数定義の前後にコメントを記述した場合は、前側の記述がドキュメントとなります。

int myapi(int myarg)

{

/* ...引数

myargには〜を指定注意点...

...仕様

myargから〜を計算して結果を返す

*/

スマート入力

挿入メニュー:スマート入力モード』をONにして文字を入力すると、自動で補完入力の候補を表示します。

]で補完候補にキーボードフォーカスを移動できます。

][]で一覧から項目を選択して[Enter]で補完入力ができます。


スマート入力は、C、C++プログラムの場合は、本ソフトウェアに内蔵されたText-Cコンパイラを利用して字句解析に加えて構文解析をおこなって入力候補を表示します。その他の言語の場合は、字句解析のみとなります。


C、C++のスマート入力は、編集テキストに加えて下記のテキストからも入力候補を検索します。ヘッダファイルに記述された関数プロトタイプからの補完入力、他のソースファイルで記述されたプログラムからの補完入力、Windows APIやC標準ライブラリの補完入力に対応します。


Windows SDKがインストールされている場合は、#include <windows.h>#include <windowsx.h>の記述でWindowsAPIのスマート入力に対応します。

スマート入力の詳細

スマート入力は、対象のファイルからシンボル一覧を作成して、シンボル一覧を元に補完入力候補を作成します。

編集テキストは、最後にディスクに保存した内容からシンボル一覧が作成されます。

ファイルのシンボル一覧は、『ツールメニュー:シンボル一覧』を実行すると閲覧できます。


シンボル一覧は、#includeファイル名、#define定義、構造体定義、クラス定義、typedef定義、ローカル関数定義、グローバル関数定義、関数宣言、グローバル変数宣言、グローバル変数、ローカル変数(自動変数は除く)からなります。それぞれの定義の箇所に付けられたコメントも、ドキュメントとしてシンボル一覧に取得します。


編集テキストで文字を入力すると、シンボル一覧から入力文字列に部分が一致する定義を取得して候補へ追加します。

また、編集テキストから入力文字列にマッチする識別子を検索して候補へ追加します。

加えて#include先のファイルなどスマート入力の対象のテキストのシンボル一覧から、語句にマッチする定義(ローカル関数とローカル変数は除く)を取得して候補へ追加します。


object.のように入力文字列の直前が`.`または`->`であり、objectの構造体やクラスが取得できた場合は、入力文字列に部分が一致するメンバーやメソッドを候補へ追加します。クラスの認識は字句解析でおこないますので、取得できない場合もあります。


C、C++プログラムやヘッダファイルの解析は、内蔵のText-Cコンパイラを使用します。

解析結果はシンボル一覧として、設定フォルダ\textsフォルダの拡張子.anaのファイルに保存されます。

解析には、下記の制約があります。

リファレンス

編集テキストの英単語の識別子にカーソルを合わせて[Shift][Shift]で、その識別子の定義内容やドキュメント、使用箇所の一覧を表示します。


構造体、メンバー、クラス、メソッド、#define、typedef、グローバル関数定義、グローバル関数宣言、グローバル変数宣言、グローバル変数の表示に対応しています。編集テキストに含まれるローカル関数定義、ローカル変数(自動変数は除く)も表示されます。


編集テキストのシンボル一覧から、識別子に一致するすべての定義とドキュメントをリファレンスに表示します。

加えて#include先のファイルなどスマート入力の対象のテキストのシンボル一覧から、ローカル関数とローカル変数を除く識別子に一致するすべての定義とドキュメントをファレンスに表示します。


object.memberのように入力文字列の直前が.または->であり、objectの構造体やクラスが取得できた場合は、識別子に一致する構造体やクラスのメンバーやメソッドのドキュメントを表示します。


加えて、編集テキストのフォルダでグローバル検索(クイックGrep)を実行して、識別子に一致する関数やメソッドの定義がある場合はそのドキュメントを表示します。

クイックGrepはフォルダのすべてのファイルが対象となりますので、他の言語の関数定義やテキストの見出しも低い優先度で表示されます。

リファレンスの末尾に、「識別子を参照しているファイル」として識別子を含むファイルの一覧が表示されます。


]と[]でリファレンスの一覧を選択して[]で詳細を表示します。[Enter]で関数などの定義箇所を本ソフトウェアで開きます。

C#プログラム

.cs ファイルは、C#プログラムとして開きます。

色分け表示は、クラスの定義、メソッドの定義、/*コメント*/、// コメント、"文字列"、'文字列'、予約語、演算子、括弧、数値、0x16進数の数値、URL、検索文字列に対応します。


アウトラインメニュー:アウトライン』を実行すると、編集領域の右側のアウトラインに、編集テキストで定義されているクラスとメソッドの一覧を表示します。クラスは見出しレベル2、メソッドは見出しレベル3で表示します。クラスの定義がネストしている場合でも常に見出しレベル2として表示します。

返り値〜関数名〜引数が1行で記述されたメソッドの認識に対応しています。記述が複数の行に分かれている場合など、関数定義を認識できないこともあります。

クラスやメソッドの定義の前または後方にコメントを記述すると、リファレンスでドキュメントとして扱います。

スマート入力

C#プログラムのスマート入力は、対象のファイルからシンボル一覧を自動で作成して、シンボル一覧を元に補完入力候補を作成します。対象のファイルが上書き更新された場合は、シンボル一覧も自動で更新されます。

シンボル一覧には下記が出力されます。

スマート入力では、編集テキストに加えて、『設定ダイアログ:入力:単語補完辞書1〜4』で指定したファイルからも入力候補を検索します。

デフォルトの設定では、『単語補完辞書1』にapi://cs.apiが指定されています。

WZ10のWEBからcs.apiをダウンロードしてWZフォルダに配置すると、「.Net Framework」のクラスおよびメソッドの一覧から候補を検索します。


編集テキストで文字を入力すると、シンボル一覧から入力文字列に部分が一致するクラスを取得して候補へ追加します。

また、編集テキストから入力文字列に部分が一致する識別子を検索して候補へ追加します。

加えて、追加ファイルのシンボル一覧から、入力文字列に部分が一致するクラスを取得して候補へ追加します。


object.のように入力文字列の直前が.の場合で、objectのクラスが取得できた場合は、入力文字列に部分が一致するメソッドとフィールド名を候補へ追加します。クラスの認識は字句解析でおこないますので、取得できない場合もあります。

リファレンス

編集テキストの英単語の識別子にカーソルを合わせて[Shift][Shift]で、その識別子の定義箇所やドキュメントをリファレンスとして表示します。ドキュメントの表示は、ユーザ定義のクラス、メソッドと、.NET Frameworkのクラス、メソッドに対応しています。


編集テキストおよび追加ファイルのシンボル一覧のクラスから、識別子に一致するすべてのクラスとドキュメントをリファレンスに表示します。


object.Compareのように識別子の直前が.の場合で、objectのクラスが取得できた場合は、クラスのメソッドから識別子に一致するドキュメントを表示します。「.NET Framework」のクラスの場合は、cs.apiからクラスのメソッドのドキュメントを表示します。


加えて、編集テキストのフォルダでグローバル検索(クイックGrep)を実行して、識別子に一致するメソッドの定義がある場合はそのドキュメントを表示します。

クイックGrepはフォルダのすべてのファイルが対象となりますので、他の言語の関数定義やテキストの見出しも低い優先度で表示されます。

リファレンスの末尾に、「識別子を参照しているファイル」として識別子を含むファイルの一覧が表示されます。

Javaプログラム

.javaファイルは、Javaプログラムとして開きます。

色分け表示は、メソッド定義、/*コメント*/、// コメント、"文字列"、'文字列'、/正規表現/、予約語、演算子、括弧、数値、0x16進数の数値、HTMLのタグと属性、URL、検索文字列に対応します。


アウトラインメニュー:アウトライン』を実行すると、編集領域の右側のアウトラインに、編集テキストのクラス名とメソッド名の一覧を表示します。クラス名は見出しレベル2、メソッド名は見出しレベル3で表示します。

返り値〜関数名〜引数が1行で記述されたメソッドの認識に対応しています。記述が複数の行に分かれている場合など、メソッドの定義を認識できないこともあります。

クラスやメソッドの定義の前または後方にコメントを記述すると、リファレンスでドキュメントとして扱います。

スマート入力

Javaプログラムのスマート入力は、対象のファイルからシンボル一覧を自動で作成して、シンボル一覧を元に補完入力候補を作成します。対象のファイルが上書き更新された場合は、シンボル一覧も自動で更新されます。

シンボル一覧には下記が出力されます。

スマート入力では、編集テキストに加えて、『設定ダイアログ:入力:単語補完辞書1〜4』で指定したファイルからも入力候補を検索します。

デフォルトの設定では、『単語補完辞書1』にapi://java.apiが指定されています。

WZ10のWEBからjava.apiをダウンロードしてWZフォルダに配置すると、「Java(tm) Platform, Standard Edition 8 API仕様」のクラスおよびメソッドの一覧から候補を検索します。


編集テキストで文字を入力すると、シンボル一覧から入力文字列に部分が一致するクラスを取得して候補へ追加します。

また、編集テキストから入力文字列に部分が一致する識別子を検索して候補へ追加します。

加えて、追加ファイルのシンボル一覧から、入力文字列に部分が一致するクラスを取得して候補へ追加します。


object.のように入力文字列の直前が.の場合で、objectのクラスが取得できた場合は、入力文字列に部分が一致するメソッドとフィールド名を候補へ追加します。クラスの認識は字句解析でおこないますので、取得できない場合もあります。

リファレンス

編集テキストの英単語の識別子にカーソルを合わせて[Shift][Shift]で、その識別子の定義箇所やドキュメントをリファレンスとして表示します。ドキュメントの表示は、ユーザ定義のクラス、メソッドと、java.apiをセットアップした場合はJava SE 8のクラス、メソッドにも対応しています。


編集テキストおよび追加ファイルのシンボル一覧から、識別子に一致するすべてのクラスとドキュメントをサイドリファレンスに表示します。


object.Compareのように識別子の直前が.の場合で、objectのクラスが取得できた場合は、識別子に一致するクラスのメソッドのドキュメントを表示します。

Java SE 8のクラスの場合は、java.apiからクラスのメソッドのドキュメントを表示します。


加えて、編集テキストのフォルダでグローバル検索(クイックGrep)を実行して、識別子に一致するメソッドの定義がある場合はそのドキュメントを表示します。

クイックGrepはフォルダのすべてのファイルが対象となりますので、他の言語の関数定義やテキストの見出しも低い優先度で表示されます。

リファレンスの末尾に、「識別子を参照しているファイル」として識別子を含むファイルの一覧が表示されます。

JavaScript

.jsファイルは、JavaScriptとして開きます。

色分け表示は、関数定義、/*コメント*/、// コメント、"文字列"、'文字列'、/正規表現/、予約語、演算子、括弧、数値、0x16進数の数値、HTMLのタグと属性、URL、検索文字列に対応します。


アウトラインメニュー:アウトライン』を実行すると、編集領域の右側のアウトラインに、編集テキストで定義した関数の一覧を見出しレベル3で表示します。見出しレベル2には//##で始まる段落を表示します。プログラムに//##グループ名を記述して関数をグルーピングできます。

関数定義の認識は、functionを含む段落から字句解析でおこないます。

関数定義の前または後方にコメントを記述すると、関数の説明(ドキュメント)として認識します。

スマート入力

JavaScriptのスマート入力は、対象のファイルからシンボル一覧を自動で作成して、シンボル一覧を元に補完入力候補を作成します。対象のファイルが上書き更新された場合は、シンボル一覧も自動で更新されます。

シンボル一覧には下記が出力されます。

スマート入力では、編集テキストに加えて、`『設定ダイアログ:入力:単語補完辞書1〜4』`で指定したファイルからも入力候補を検索します。

デフォルトの設定では、『単語補完辞書1』にapi://js.apiが指定されています。

WZ10のWEBからjs.apiをダウンロードしてWZフォルダに配置すると、「mozilla.org/JavaScript/Reference/標準ビルトインオブジェクト」のクラスおよびメソッドの一覧から候補を検索します。


編集テキストで文字を入力すると、シンボル一覧から入力文字列に部分が一致する関数とプロパティを取得して候補へ追加します。

また、編集テキストから入力文字列に部分が一致する識別子を検索して候補へ追加します。

加えて、追加ファイルのシンボル一覧から、入力文字列に部分が一致する関数とプロパティを取得して候補へ追加します。

api://js.apiから、入力文字列に部分が一致が一致するクラス名を候補へ追加します。


object.のように入力文字列の直前が.の場合は、メソッドまたはプロパティを候補へ追加します。

var obj = new String();obj.のようにオブジェクトが標準ビルトインオブジェクトのクラスの場合は、入力文字列に部分が一致するメソッドとフィールド名を候補へ追加します。

その他の場合は、シンボル一覧から入力文字列に部分が一致するプロパティ名を候補へ追加します。

リファレンス

編集テキストの英単語の識別子にカーソルを合わせて[Shift][Shift]で、その識別子の定義箇所やドキュメントをリファレンスとして表示します。ドキュメントの表示は、関数定義、標準ビルトインオブジェクトのクラスとメソッドに対応しています。


編集テキストおよび追加ファイルのシンボル一覧の関数定義から、識別子に一致するすべての関数定義とドキュメントをリファレンスに表示します。


obj.substrのように識別子の直前が.の場合は、クラスのメソッドまたは関数定義を検索します。

var obj = new String();obj.substrのようにオブジェクトが標準ビルトインオブジェクトのクラスの場合は、識別子に一致するメソッドのドキュメントを表示します。

その他の場合は、シンボル一覧の関数定義から識別子が一致するドキュメントを表示します。


加えて、編集テキストのフォルダでグローバル検索(クイックGrep)を実行して、識別子に一致する関数定義がある場合はそのドキュメントを表示します。

クイックGrepはフォルダのすべてのファイルが対象となりますので、他の言語の関数定義やテキストの見出しも低い優先度で表示されます。

リファレンスの末尾に、「識別子を参照しているファイル」として識別子を含むファイルの一覧が表示されます。

PHPプログラム

.phpファイルは、PHPプログラムとして開きます。

色分け表示は、メソッド定義、/*コメント*/、// コメント、#コメント、、"文字列"、'文字列'、$変数名、<?...?>、予約語、演算子、括弧、数値、0x16進数の数値、#16進数の数値、HTMLのタグと属性、URL、検索文字列に対応します。


アウトラインメニュー:アウトライン』を実行すると、編集領域の右側のアウトラインに、編集テキストで定義されたクラス名を見出しレベル2で、メソッド名および関数名の一覧を見出しレベル3で表示します。

関数定義の認識は、functionを含む段落から字句解析でおこないます。

クラスや関数定義の前または後方にコメントを記述すると、リファレンスでドキュメントとして扱います。

スマート入力

PHPプログラムのスマート入力は、対象のファイルからシンボル一覧を自動で作成して、シンボル一覧を元に補完入力候補を作成します。対象のファイルが上書き更新された場合は、シンボル一覧も自動で更新されます。

シンボル一覧には下記が出力されます。

スマート入力では、編集テキストに加えて、『設定ダイアログ:入力:単語補完辞書1〜4』で指定したファイルからも入力候補を検索します。

デフォルトの設定では、『単語補完辞書1』にapi://php.apiが指定されています。

WZ10のWEBからphp.apiをダウンロードしてWZフォルダに配置すると、「php.net:マニュアル内の全関数」の関数一覧から入力候補を検索します。


編集テキストで文字を入力すると、シンボル一覧から入力文字列に部分が一致する関数とクラス名を取得して候補へ追加します。

また、編集テキストから入力文字列に部分が一致する識別子を検索して候補へ追加します。

加えて、追加ファイルのシンボル一覧から、入力文字列に部分が一致する関数とクラス名を取得して候補へ追加します。


$object->のように入力文字列の直前が->であり、その手前に$object = new クラス名;の記述がある場合は、シンボル一覧からクラスを検索して、入力文字列に部分が一致するメソッドを候補へ追加します。

リファレンス

編集テキストの英単語の識別子にカーソルを合わせて[Shift][Shift]で、その識別子の定義箇所やドキュメントをリファレンスとして表示します。関数、クラス、メソッドの表示に対応しています。


編集テキストおよび追加ファイルのシンボル一覧から、識別子に一致するすべての関数、クラスの定義とドキュメントをリファレンスに表示します。


$object->methodのように識別子の直前が->であり、その手前に$object = new クラス名;の記述がある場合は、シンボル一覧からクラスを検索して、識別子に一致するメソッドのドキュメントを表示します。


加えて、編集テキストのフォルダでグローバル検索(クイックGrep)を実行して、識別子に一致する関数、クラス、メソッドの定義がある場合はそのドキュメントを表示します。

クイックGrepはフォルダのすべてのファイルが対象となりますので、他の言語の関数定義やテキストの見出しも低い優先度で表示されます。

リファレンスの末尾に、「識別子を参照しているファイル」として識別子を含むファイルの一覧が表示されます。

Pythonプログラム

.pyファイルは、Pythonプログラムとして開きます。

色分け表示は、'''コメント、#コメント、'文字列'、予約語、検索文字列に対応します。


アウトラインメニュー:アウトライン』を実行すると、編集領域の右側のアウトラインに、編集テキストで定義された関数の一覧を見出しレベル3で表示します。

関数定義の認識は、行頭がdefから始まる段落から字句解析でおこないます。

スマート入力

Pythonプログラムのスマート入力は、識別子の入力のみの対応となります。

プログラムを解析したシンボル一覧からの入力には対応しておりません。


編集テキストから入力文字列に部分が一致する識別子を検索して候補へ追加します。

編集テキストに加えて、『設定ダイアログ:入力:単語補完辞書1〜4』`で指定したファイルからも識別子の入力候補を検索します。

リファレンス

Pythonプログラムのリファレンスは、クイックGrepのみの対応となります。


編集テキストの英単語の識別子にカーソルを合わせて[Shift][Shift]で、編集テキストのフォルダでグローバル検索(クイックGrep)を実行して、識別子に一致する関数の定義がある場合はそのファイル名を表示します。

クイックGrepはフォルダのすべてのファイルが対象となりますので、他の言語の関数定義やテキストの見出しも低い優先度で表示されます。

リファレンスの末尾に、「識別子を参照しているファイル」として識別子を含むファイルの一覧が表示されます。

その他のプログラム

.asm .bas .cgi .css .for .hsp .ini .lisp .mscr .pas .pl .rb .ruby .sql .v .vhd .vhdlファイルは、それぞれのプログラム言語やスクリプトを自動で判別して、言語に応じた色分け表示と関数定義のアウトラインの表示をおこないます。


スマート入力とリファレンスは、「Pythonプログラム」と同じく識別子のみの対応となります。詳細は「Pythonプログラム」をご覧ください。

Zip、Epub

.zip .epubファイルを開くと、アーカイブ内のファイル一覧を表示します。


一覧からファイルを選択してOKすると、アーカイブからファイルを展開して本ソフトウェアで開きます。

編集して上書き保存を実行すると、ファイルを圧縮してアーカイブに保存します。

イメージファイル

.jpg .jpeg .png .bmpファイルは、イメージファイルとして開いて画像を表示します。

バイナリファイル

.exeファイルなどのバイナリは、「バイナリ編集」として開きます。ファイルのデータを文字コードや改行コードの判定をしないでダイレクトに読み込みます。


ファイルの内容は、バイト単位の00-FFの16進数値で表示されます。

0]-[F]のキー入力と、[Del]と[BS]でバイナリデータを編集できます。


バイナリ編集と通常編集を切り替るには、『ファイルメニュー:バイナリ編集』を実行します。

ファイルタイプのカスタマイズ

拡張子のファイルをどのように編集するかの情報は、ファイル設定で定義されています。

設定をするには、『ファイルメニュー:ファイル設定の一覧』を実行します。


ファイル設定の一覧ダイアログが表示されます。一覧の`+`をクリックすると、設定に関連付けられた拡張子を表示します。拡張子の関連付けの設定または解除は、登録または登録解除のクリックでおこないます。


設定を変更するには、{編集}をクリックします。

ファイルタイプの指定は、目次ファイル:ファイル形式をクリックして、『テキスト形式』と『プログラム』の項目から選択します。

PageTop