WZ Writing Editor 3
マニュアル
WZ soft > WZ Writing Editor 3 > マニュアル >
設定
WZW3の設定には、スタイル、下書きスタイル、文書形式、環境設定の4つがあります。
「スタイル」では、原稿の文字数×行数、段組、フォント、縦書き、余白、用紙、段落体裁、行番号の表示と印刷のオプションを設定します。「スタイル」には任意の名前を「A4横書き」「A4縦書き(2段組)」のように付けて、複数のスタイルを登録しておいてファイル毎に切り換えて使用できます。デフォルトで14種類のスタイルがあらかじめ用意されています。
「下書きスタイル」では、下書き表示モードでの文字数×行数、段組、フォント、縦書き、余白、行番号の表示のオプションを設定します。「下書きスタイル」にも任意の名前を「横書き2段」「縦書き」のように付けて、複数のスタイルを登録しておいてファイル毎に切り換えて使用できます。デフォルトで8種類のスタイルがあらかじめ用意されています。
「文書形式」では、原稿のタグ、自動ファイル名、フリーカーソル、オートインデント、見出し、段落体裁認識、脚注の編集オプションを設定します。通常はデフォルトの設定でご使用いただけます。
「環境設定」では、キー定義、テキストの表示色、ウィンドウサイズを設定します。環境設定はすべての文書ファイルに適用されます。
印刷表示モードと下書き表示モード
印刷表示モードでは、原稿の印刷イメージに近い表示で編集作業ができます。テキストは「スタイル」の設定で表示します。
下書き表示モードでは、原稿テキストの表示速度を優先して編集作業ができます。表示速度は約2倍です。テキストは「下書きスタイル」の設定で表示します。組版、装飾、体裁など多数の機能はOFFとなります。下書きモード専用の禁則処理で文章を表示します。印刷表示モードの禁則処理とは動作が異なります。
印刷表示と下書き表示モードを切り替えるには、『表示メニュー:下書き』または、ツールバーの『下書き』のチェックボックスで操作します。
スタイルの切り替え
WZW3では、原稿のテキストファイル単位のスタイルの切り替えに対応しています。文書ファイルAは「A4横書き」、文書ファイルBは「B5縦書き」などを選択できます。一度選択すると、文書ファイルを閉じても選択したスタイルを記憶しています。次回に文書ファイルを開くと、前回選択したスタイルで表示します。
スタイルの選択をするには、下記の操作をおこないます。
- 『表示メニュー:スタイルの一覧』を実行
スタイルの一覧ダイアログが表示されます。 - 一覧からスタイルを選択
選択するたびに、画面表示を指定のスタイルに切り替えます。 - OKすると、選択したスタイルに切り替えを確定
キャンセルすると、選択を取り消して実行前の表示に戻ります。
選択したスタイルは、WZW3の「プロファイル」という仕組に記憶します。プロファイルには、3000個までの文書ファイルの設定を記憶できます。3000個を越えた場合は、古い順に設定が消去されます。
縦書きと横書き
縦書きと横書きを切り替えるには、下記の操作でスタイルを切り替えます。
- 『表示メニュー:スタイルの一覧』を実行
- 縦書き表示にするには、一覧から縦書きのスタイルを選択
横書き表示にするには、一覧から横書きのスタイルを選択してOK
ツールバーの「縦書き/横書き表示の切り替え」ボタンで、編集テキストの縦書きと横書きの表示の切り替えにも対応しています。
- 縦書き表示に切り替えると、ツールバーのボタンのチェックボックスをONにします。
- 横書き表示に切り替えると、チェックボックスをOFFにします。
縦書き表示では、1桁や2桁の半角数字を横組みで表示する縦中横の表示オプションに対応しています。
- 『表示メニュー:設定』を実行
- 基本タブをクリック
- 「縦中横」のオプションを選択してOK
設定ダイアログと専用設定
『表示メニュー:設定』を実行すると設定ダイアログを表示します。編集テキストに適用されている設定内容を表示します。
印刷表示モードでは、「スタイル」「文書形式」「環境設定」の設定を一括して表示します。下書き表示モードでは、「下書きスタイル」「文書形式」「環境設定」を一括して表示します。
ダイアログで文字数、行間、フォントなど「スタイル」または「下書きスタイル」の項目を変更するとリアルタイムで編集テキストの表示を更新します。行間やフォントの項目を変更すると直ちにテキストの表示に反映されるため、行間やフォントの表示を確認しながら設定することができます。
ダイアログでキャンセルすると編集テキストの表示を元に戻します。ダイアログでOKすると「スタイル」設定を更新しますか?または「下書きスタイル」設定を更新しますか?を問い合わせします。『更新する』で、スタイル設定を上書きして確定します。『専用設定にする』で、編集テキスト専用のスタイルとして確定します。『キャンセル』で設定ダイアログに戻ります。
専用設定では、他のテキストとは独立して、編集テキスト専用のスタイル設定がおこなえます。以後、設定ダイアログでOKしたときには更新の問い合わせはおこなわず直ちに設定を確定します。
ワープロソフトでは、一般的に設定は文書ファイルに保存されますが、テキストエディタのWZW3では、スタイルや文書形式の設定は文書ファイルとは別の専用ファイルに記憶されます。専用設定はプロファイルに保存されます。
文字フォントの指定
設定ダイアログでフォントを指定するには「フォント」のドロップダウンリストボックスから漢字またはカタカナの名前のフォントを選択します。
スタイル設定と環境設定のフォントの設定項目では、全角文字と半角文字のフォントを個別に指定できます。下書きスタイルでは全角文字のフォントのみ指定でき、半角文字は指定した全角文字フォントに含まれる半角フォントが使用されます。
全角文字のフォントは、フォントの一覧からMS 明朝、メイリオなど名前に全角文字を含むフォントを指定します。
半角文字のフォントは、Times New Roman、Arialなどの名前が半角文字のフォントを指定します。
一時設定
WZW3のツールバーでは、「画面幅」「タグ」「縦書き/横書き」の一時的な設定変更ができます。設定変更はファイル単位に保存され、ファイルを閉じても次回のオープンで復元されます。
ツールバーでの設定変更は、一時的な変更となります。設定ダイアログでOKするとツールバーでの設定変更は無効となり、ダイアログでの設定が優先されます。
一時設定には、下記があります。
- 表示メニュー「画面幅で折り返し(一時設定)」
- 表示メニュー「タグ(一時設定)」
- 表示メニュー「縦書き(一時設定)」
- ツールバー「画面幅(一時設定)」
- ツールバー「タグ(一時設定)」
- テキスト/アウトライン境界線のドラッグによる、アウトラインの表示幅の変更
- ステータスバーの「表示ズーム」
一時的な変更は、設定には影響を与えません。設定ダイアログを開いても、一時的な変更は反映されていません。設定ダイアログをOKすると、一時的な変更は解除となります。
登録済みのスタイル
デフォルトでは、下記のスタイルが登録されています。
スタイルの設定やスタイルの名前は、任意に変更できます。また、任意の設定を追加できます。
- [標準] A4横書き
- A4サイズ 1段組 MS明朝 12ポイント 標準スタイル
- A4横書き(2段組)
- A4サイズ 2段組 MS明朝 9ポイント
- A4横書き(雑誌原稿)
- A4サイズ 3段組 MS明朝 9ポイント
- B5横書き
- B5サイズ 1段組 MS明朝 12ポイント
- A4縦書き
- A4サイズ 縦書き MS明朝 12ポイント
- A4縦書き40文字30行
- A4サイズ 縦書き MS明朝 12ポイント 40文字×30行指定
- A4縦書き30文字40行
- A4サイズ 縦書き MS明朝 12ポイント 30文字×40行指定
- A4縦書き40文字40行
- A4サイズ 縦書き MS明朝 12ポイント 40文字×40行指定
- A4縦書き40文字(見開き)
- A4サイズ 縦書き MS明朝 12ポイント 40文字×40行指定 袋とじ
- B5縦書き
- B5サイズ 縦書き MS明朝 9ポイント
- B5縦書き40文字40行
- B5サイズ 縦書き MS明朝 9ポイント 40文字×40行指定
- B5縦書き40文字(見開き)
- B5サイズ 縦書き MS明朝 9ポイント 40文字×40行指定 袋とじ
- B5縦書き20文字(原稿用紙)
- B5サイズ 縦書き MS明朝 18ポイント 400字詰 行罫 文字罫
- B5縦書き20文字(見開き・原稿用紙)
- B5サイズ 縦書き MS明朝 18ポイント 400字詰 袋とじ 行罫 文字罫
※Windows 8.1以降では、「MS明朝」の代わりに「游明朝」の設定となります。
スタイルの新規登録
スタイルを新規に作成するには、下記の操作をおこないます。
- 『表示]メニュー:[設定』を実行
- 『設定の操作』をクリック
- 『スタイルの新規作成』をクリック
- 名前を入力してOK
現在使用している設定の内容で、指定した名前のスタイルが新規に作成されて、現在の文書に適用されます。
スタイルの登録の個数に制限はありません。
スタイルのメンテナンス
スタイルの名前の変更、削除、順序を入れ替えるには、下記の操作をおこないます。
- 『表示メニュー:スタイルの一覧』を実行
- 対象とするスタイルを一覧から選択
- 『名前の変更』『削除』『↑』『↓』を実行してメンテナンスを実行
※「標準」スタイルは、削除することができません。
スタイルのカスタマイズをすべてクリアして追加したスタイルをすべて削除して、WZW3の初期状態に戻すには、下記の操作をおこないます。
- 『表示]メニュー:スタイルの一覧』を実行
- 『初期化』を実行
- 確認に「はい」を選択
高精細の文字表示
Windows10上では、設定ダイアログの表示タブの『文字の描画』設定で、文字の表示品質を指定できます。基本、精細、高精細の順に文字を滑らかに表示します。
- Windows11では基本の品質に固定です。文字を滑らかに表示します。設定項目は有りません。
- 文字の描画は、表示専用の設定です。印刷では無効となります。
- 縦書き表示では、ダッシュなど一部の記号の向きが不自然な場合があります。Windows10の細かいバージョンによって向きが異なる場合があります。『文字の描画』設定に精細を指定すると改善される場合があります。
- 高解像度ディスプレイなど環境によって文字欠けが発生する場合があります。この場合は基本に設定します
- 精細表示は、Windows OSの制限により「MS明朝」「MSゴシック」の16ポイント未満の文字には対応していません
- 縦書きの精細表示は、下記のフォントで動作を確認しています。その他のフォントの表示は、サポートの対象外となります
MS 明朝、MS ゴシック、メイリオ、游明朝、游ゴシック - 精細表示、高精細表示は、Unicode特有文字の縦書き表示に対応しますが一部対応しない文字もあります。基本表示にすると、Unicode特有文字は横書きの表示となります
縦書きの精細表示は、下記の制約があります。
- 長音記号「ー」の筆入りは右からの表示となります
- 「�燹廖岫瓠弋�号の表示形態が異なります
- 文字の上部が欠ける場合があります
- 句読点や記号の表示位置がずれる場合があります
印刷表示モードでの精細・高精細表示は、印刷出力の文字幅をもとにおこないます。表示用の自然な文字幅と異なりますので、不自然な文字間隔の表示となる場合があります。
色分け表示
WZW3では、本文の文字、本文背景、偶数行の背景、選択文字、選択背景、全角/半角空白、改行、引用、コメント、URL、任意の語句と括弧内の文字列の色分け表示と、特定の語句を含む段落の背景色の色分けに対応しています。
色の指定は、設定ダイアログの色分けタブで一括設定します。文字や背景の色はダイアログの色指定ボックスをクリックして色を設定します。
引用などの文字列の色分けは下記のように指定します。
引用
先頭が>または>で始まる段落を色分け表示します。
引用の段落認識は、正規表現による指定も可能です。
コメント
先頭が#または#で始まる段落を色分け表示します。
コメントの段落認識は、正規表現による指定も可能です。
URL
WEBページやメールアドレスを自動判別して色分け表示します。URLの色分け箇所をを[Ctrl+クリック]するとブラウザで開きます。アドレスの完全な判別には対応しておりません。
語句と括弧内の文字列
『語句の色分け1〜5』に色分けする語句や括弧記号を指定します。複数の語句を指定するには、語句を空白で区切って指定します。語句に英単語のみを指定した場合は、大文字小文字を区別して単語の色分けをおこないます。「Write」を指定した場合に、「Writer」は色分け表示がされません。
語句の色グループの『語句1〜5』で指定した色と装飾(太字/下線)で表示されます。
段落の括弧内の文字列を色分け表示するには、語句に括弧記号を指定します。
下記の括弧記号の指定に対応しています。
- 半角括弧
- <> {} [] ()
- 全角括弧
- ()〔〕[]「」『』�爿瓠磧�
※全角括弧は、青空文庫ルビのタグの色分けが適用されますので、括弧内の文字列の色分けには対応しておりません。
段落の背景色
『段落背景の色分け1〜3』に色分けする語句を指定します。指定した語句を含む段落全体の背景が色分け表示されます。語句には正規表現も指定できます。
基本色グループの『段落背景1〜3』で指定した色で表示されます。
行数やページ数のカウント
編集テキストのカーソル位置のページ数と行数は、ステータスバーに表示されます。文章の変更や追加の度に、自動的に再計算して行数やページ数の表示が更新されます。入力中の原稿の全体量を確認しながらの執筆や、文字数と行数の指定された原稿の作成に対応します。
印刷表示モードでは、文章の折り返しは表示と印刷で同一のため、行数の表示も一致します。「画面幅」の折り返しをONにした場合は、印刷とは異なります。
本文の横にページ数や行数を表示するには、下記の操作をおこないます。
- 『表示メニュー:設定』を実行
- 基本タブをクリック
- 行番号とルーラーグループの『行番号を表示』のチェックボックスをONにしてOK
ページ数の表示は、印刷プレビューでは印刷結果と一致します。編集画面では、下記の場合に若干の誤差が生じる場合があります。
- 図や小見出を含む文書
- 見出しの行取りを小数点まで指定した文書
- 段落体裁や見出しのフォントサイズを変更した文書
編集画面では、下記の場合にページ番号の表示がOFFとなり、通しの行番号を表示します。
- 「画面幅」の折り返し表示をONにした場合
- 設定で『行番号の種類』に表示行(通し)または段落行を指定した場合
- 設定で『用紙』に指定しないと、『文字数・行数』に用紙サイズから計算を指定した場合
文字数や枚数のカウント
WZW3では、文書の行数、バイト数、ページ数、字数、文字数、文字数(空白なし)、漢字、ひらがな、カタカナ、英単語数、Unicode特有文字数、40文字行数(概算)、原稿用紙枚数(概算)のリアルタイム表示に対応しています。文章の変更や追加の度に、自動で再計算して表示が更新されます。
字数、原稿用紙枚数はステータスバーに表示されます。
字数は、カーソル位置の段落の字数を表示します。選択すると、範囲内の字数を表示します。カーソル位置が見出しの場合は、見出し内の字数を表示します。段落の字数が0の場合は、見出し内の字数を表示します。
字数のカウントは、設定ダイアログ入力タブ字数カウントでカスタマイズできます。漢字を1字または2字でカウント、半角を1字または0.5字でカウントなど詳細を設定できます。
その他の文字数を表示するには、『ツールメニュー:文字数行数カウンタ』を実行します。ツールビューにカウンタツールが表示されます。指定の範囲内の文字数カウントにも対応しており、範囲を選択をすると範囲内の文字数も表示されます。
※「40文字行数」と「原稿用紙枚数」は、概算値となります。正確な行数と枚数を計算するには、スタイルを「原稿用紙」に切り替えてページ数や行数を表示します。
下記の操作でステータスバーに文字数を表示することもできます。
- 『表示メニュー:設定』を実行
- インターフェースタブをクリック
- メニューバーグループの『ステータスバー表示内容』の...をクリック
「ステータスバーのステータスツール」ダイアログが表示されます。 - 必要な文字数カウントのチェックボックスをONにしてOK
- 設定ダイアログをOK
タブとウィンドウ
WZW3で同時に複数のファイルを開くと、ウィンドウに複数のタブを開いて文書ファイルを表示します。タブにはファイル名を「txtファイル」の拡張子を省略して表示します。
文書ファイルを切り替えるには、4種類の操作方法があります。
- 切り替え先のタブをクリック
- 『ウィンドウメニュー:ウィンドウ一覧』を実行して、ウィンドウ一覧ダイアログから切り替える
- 『ウィンドウメニュー:タブの切り替え』を実行して、直前の文書と交互に切り替える
- [Ctrl+Tab]を数回押して、文書を切り替える
ウィンドウは分割して、ファイルを左右・上下に並列表示することもできます。下記の操作をおこないます。
- 『ウィンドウメニュー:分割ビューの切り替え』を実行
- 文書のタブをドラッグアンドドロップして文書の並びを変更
文書のタブはドラッグアンドドロップに対応しています。
- タブをドラッグして、他の分割ビューへドロップするとタブを移動します
- タブをドラッグして、他のウィンドウにドロップするとタブを移動します
- タブをドラッグして、他のアプリケーションにドロップすると、ファイルをそのアプリケーションで開きます
- タブをドラッグして、デスクトップやエクスプローラにドロップするとファイルをコピーします
文書のタブの右クリックメニューで、下記の操作も可能です。
- ソート
- タブの並びを文書のファイル名や更新時間でソートします
- タブの設定
- 環境設定のタブの設定項目を表示します
縦書き/横書き、上下/左右、変更文書の太字表示を設定します - タブを表示する/隠す
- タブの表示のON/OFFを切り替えます
- クリップボードに出力
- タブのファイル名とテキストの内容をクリップボードに出力します
ウィンドウ位置の記憶復元
WZW3のウィンドウは、位置とサイズを記録、復元したり、規定の位置に移動できます。
ウィンドウの位置とサイズを記録するには、下記の操作をおこないます。
- 『ウィンドウメニュー:画面位置の記憶』を実行
「ウィンドウ位置の記憶復元」ダイアログが表示されます - 『追加』を実行で、一覧の先頭に記録されます
『編集』を実行すると、任意のタイトル名を指定できます
タブやウィンドウの多重化と独立表示
1つの文書ファイルを複数のタブまたはウィンドウで開くことができます。テキストの2箇所の同時表示、縦書きと横書きの並列表示、編集画面表示と印刷プレビューの同時表示に対応しています。
複数で開くには下記の操作をおこないます。
- 『ウィンドウメニュー:多重化』または『ウィンドウメニュー:多重化 別ウィンドウ』を実行
複数表示のそれぞれのカーソル位置の同期を設定するには、下記の操作をおこないます。
- 『ウィンドウメニュー:多重化のカーソル位置を同期』を実行
「テキストの2箇所の同時表示」の場合は、同期をOFFにします。
「縦書きと横書きを同時表示」の場合は、同期をONにします。
多重化のタブやウィンドウを閉じると、専用のプロファイルにカーソル位置を記憶します。多重化を再度実行すると、前回のカーソル位置を表示します。
別ウィンドウ独立表示
タブで開いている文書ファイルを、タブから切り離して別のウィンドウで表示できます。下記の操作をおこないます。
- 文書のタブをダブルクリック
タブに戻すには、下記の操作をおこないます。
- 文書のタブをドラッグアンドドロップして、元のウィンドウへ移動
プレーン表示とタイプライターモード
プレーン表示では、メニューやステータスバーを省いてテキストをウィンドウいっぱいに表示します。プレーン表示にするには、『ウィンドウメニュー:プレーンモード』を実行します。
プレーン表示では、マウスカーソルをWZのウィンドウ上方に動かすとメニューバー、ツールバー、タブバーを表示しますので、メニュー操作などが可能です。マウスカーソルをウィンドウ下方に動かすとステータスバーを表示しますので、文書の情報を確認できます。キー操作[Alt+F][Alt+E][Alt+S][Alt+V][Alt+I][Alt+O][Alt+T][Alt+W]で、それぞれ「ファイル」「編集」「検索」「表示」「挿入」「アウトライン」「ツール」「ウィンドウ」メニューを表示しますので、キーボードでもメニューコマンド操作も可能です。
プレーン表示では、ウィンドウの移動やリサイズがマウスでできません。移動やリサイズをするには、『ウィンドウメニュー:プレーンモード』を実行してプレーン表示を解除してください。
WZW3を終了するとプレーン表示は解除されます。常時、プレーン表示にしたい場合は、『設定ダイアログ:インターフェース:ウィンドウ:プレーンモード』をONにします。この場合でも『ウィンドウメニュー:プレーンモード』を実行すると一時的にプレーン表示の解除ができます。
WZW3ではタイプライターモードをONにすることも可能です。デフォルトでは無効となっております。タイプライターモードでは、カーソルを常にウィンドウの中央に表示します。タイプライターモードにするには『カーソルの行位置を固定』をONにします。カーソルの表示位置は、横書きと横書きで個別に好みの位置に変更することもできます。設定ダイアログ:表示:テキストの表示の『カーソルの固定位置』と『固定位置(縦書き)』で指定します。
※『ページめくり』がONの場合や『段組』が2以上の場合には、タイプライターモードは無効となります。
更に下書き表示モードでは、カーソルの行を他より大きく表示して目立たせることができます。『カーソル行以外を小さく表示』をONにして『表示サイズ』を%で指定できます。印刷表示モードでは無効となります。
カーソル移動
文字単位、単語単位、行単位、段落単位のカーソルの移動に対応しています。
- [←][→]
- 文字単位でカーソルを移動
- [↑][↓]
- 行単位でカーソルを移動
- [Ctrl+←][Ctrl+→]
- 単語単位でカーソルを移動*
- [Home]
- 行頭へカーソルを移動*
- [End]
- 行末へカーソルを移動*
- [Ctrl+Home]
- 文書先頭へカーソルを移動*
- [Ctrl+End]
- 文書末尾へカーソルを移動*
- 『検索メニュー:ジャンプ』
- ジャンプダイアログを表示(段落、行、ページ、最後の編集箇所、URL、見出し、変更行へ移動可能)
- 『表示メニュー:カーソル位置の切り替え』
- カーソルの表示位置を「画面上部」「中央部」「下部」へ移動(カーソルの編集位置は保ちます)
*は、Windows標準標準キー定義で有効となります。
マーク箇所の記憶復元
『マーク』を使用すると、文書位置のマーク1〜4への記憶と、記憶した位置へ戻ることができます。
テキストの別の箇所を編集する前に現在の編集位置をマークしておくと、編集後にマーク位置に戻れます。
「マーク」機能は、『検索メニュー:マーク』から実行します。
- 『マーク1に記憶』を実行すると、マーク1にカーソル位置を記憶します
- 『マーク1へジャンプ』を実行すると、マーク1に記憶した場所に戻ります
- 『マーク一覧』を実行すると、マーク位置の一覧を表示します
マークした位置は、ファイルを閉じてもプロファイルに記憶されます。
テキストを編集してマーク位置が移動しても、自動的に記憶の位置が調整されます。
マウス操作
編集画面では、クリック、ドラッグ、右クリックなどのマウス操作に対応しています。
設定ダイアログインタフェースタブマウスグループの項目で、マウスカーソルの消去、スクロール速度、ホイールの設定がおこなえます。
- クリック
- クリックした箇所へカーソルを移動
- ダブルクリック
- クリック箇所へカーソルを移動、単語単位の範囲選択を開始、続けてドラッグで範囲選択を拡大
- トリプルクリック
- クリック箇所へカーソルを移動、段落単位の範囲選択を開始、続けてドラッグで範囲選択を拡大
- 4回クリック
- クリック箇所へカーソルを移動、文章全体を選択
- Shift+クリック
- 範囲選択を開始、クリック箇所へカーソルを移動(範囲選択中は選択開始地点からクリック箇所までを選択)
- ドラッグ
- 文字単位の範囲選択の開始、範囲の変更
- Alt+ドラッグ
- 箱型範囲選択(矩形選択)の開始、範囲の変更
- Alt+クリック
- カーソル位置からクリック箇所まで、箱型(矩形)選択
- 右クリック
- コンテキストメニューを表示
- Ctrl+クリック
- URL上で実行すると、WEBブラウザやメーラーで開く
- OLEドラッグアンドドロップ
- 範囲選択内をドラッグして他ウィンドウへのドロップで、ドラッグアンドドロップを実行
- ドロップ
- エクスプローラやデスクトップのアイコンのWZ Writing Editor 3へのドロップで、ファイルを開く
- 右ドロップ
- エクスプローラやデスクトップのアイコンをマウス右ボタンでWZ Writing Editor 3にドロップすると、ファイル名またはファイル内容の挿入メニューを表示
- 行番号のクリック、ドラッグ
- 行単位の選択の開始、範囲の変更
- タイトルバーの右クリック
- 「タイトルバー」「メニューバー」「ステータスバー」のカスタマイズメニューを表示(メニューバーとツールバーの余白部分の右クリックでも表示)